I am having trouble getting Ubuntu 14.04.1 LTS to work on my laptop, which is a Medion MD 96320 / WAM 2070. I think the specifications are: Turion 64 X2 @ 1.8 GHz processor, 2 GB RAM, GeForce Go 6150 graphics card, and a 160 GB hard drive.

I have tried installing this operating system three times now. I've tried both with having the installer install the updates, as well as without updates. No matter what I do, it installs fine, but then freezes up as soon as I log in.

I have done so much googling about this issue, but can't find anything that's helped me resolve it. I found a few posts talking about Nvidia driver issues, and about running sudo apt-get install nvidia-current and so on. I tried that before and it somehow just got even more broken and mangled, and wouldn't even boot up anymore, so I had to reinstall Ubuntu yet again. Now I can't even try that anymore. I did a fresh boot, and as usual it freezes up when I log in. But now I can't even access the terminal to try anything - pressing Ctrl+Fn+F2 at the login screen just takes me to a black screen with a "_" character drawn in the top-left corner, but I can't type anything.

What am I supposed to do? How do I get this to work?

I don't have a lot of experience with Linux, but it's always intrigued me and I was excited to play with Ubuntu, so this is really disappointing. This is the third time I have attempted to use Linux in my life (with different distros and computers), and it never, ever, ever works. It's so incredibly frustrating to just keep trying the same thing over and over and have it never work. I was really hoping that I could give this old laptop a "new lease of life" as they say, due to Linux running better on weaker hardware than Windows. I'd really appreciate it if someone could help me figure out how to fix this.

Thanks, and Merry Christmas.


I have the same trouble. Same "_". In my searching for the answer, this works for me:

Select "advanced options" on the grub boot menu, and then the second choice (first "recovery mode"). In the menu, activate the network, and go to root. At the command line type:

apt-get update
apt-get install --reinstall ubuntu-desktop
apt-get install unity
apt-get remove --purge nvidia*
shutdown -r now

I don't have a Nvidia card, dont' care. :-)

But after this unity-desktop reinstall my Ubuntu comes back.

Hope it help.


I have had similar frustrations John. always_noob's link... Ubuntu 14.04 LTS crashes after login did provide some help... but in addition to the link below.


I restarted system in recovery mode as per: Ubuntu 14.04 LTS crashes after login

connected to my wifi; went to terminal;

$ sudo apt-get --purge remove xserver-xorg-video-nouveau


$ sudo ubuntu-drivers devices

With my system nvidia-173 came up (as well as 304);

$ sudo apt-get install nvidia-173

After install went to additional drivers page as per: Ubuntu 14.04 LTS crashes after login

I could actually see a range of drivers now, clicked the 304 (not 304 update). Restarted the system, and no more freeze screen after login.

Apologies for my noob approach and write up. I've had Ubuntu a week now trawling forums (on a separate laptop) trying to get the thing to not freeze after login.



PPA from https://launchpad.net/~townsend/+archive/ubuntu/compiz-nvidia-refresh-test is worth to try. Seems to be compiz problem with Geforce 7025.

  • 1
    always best to précis the essential elements of any link you provide as your answer to a question since links have a habit of disappearing rendering your otherwise helpful solution meaningless. – 24601 Mar 11 '15 at 13:44

I'd same problem. I used NVidia control panel's "Save to X Configutaion File" button with nothing entered in textbox. My goal was to enable 3rd monitor but instead on next boot system freezes right after login screen. It also started showing big NVidia logo at the startup.

Here's what I did to fix it:

  1. Reboot and choose Advanced Options for Ubuntu and then chose Recovery Mode for whatever is the latest version.
  2. Recovery mode will show lots of options like clean, failsafe X etc. Choose dropdown to root shell. This will give you command prompt at the botton.
  3. Type mount -o remount,rw /to make file system writable.
  4. Type mv /etc/X11/xorg.conf /etc/X11/xorg.conf.bad. This basically resets X config.
  5. Reboot!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.