9

I've changed my old laptop with a new one but I don't understand why using on both virt-manager the qemu-system-x86 on new one takes 100% of CPU when run a vm, while on old one not.

The command:

lscpu

has this output:

Architecture:          x86_64
CPU op-mode(s):        32-bit, 64-bit
Byte Order:            Little Endian
CPU(s):                4
On-line CPU(s) list:   0-3
Thread(s) per core:    2
Core(s) per socket:    2
Socket(s):             1
NUMA node(s):          1
Vendor ID:             GenuineIntel
CPU family:            6
Model:                 69
Stepping:              1
CPU MHz:               754.000
BogoMIPS:              5187.74
Virtualization:        VT-x
L1d cache:             32K
L1i cache:             32K
L2 cache:              256K
L3 cache:              4096K
NUMA node0 CPU(s):     0-3

While in my old PC it just uses 15%-30% of the CPU. I've also actived the kvm from the BIOS but nothing changes: it continues to use 100%.

The top command gives me:

PID USER      PR  NI    VIRT    RES    SHR S  %CPU %MEM     TIME+ COMMAND
3410 libvirt+  20   0 3641892 902428  10332 S 101,4 11,2   1:03.36 qemu-system-x86

How should I proceed?

  • This indicates that you have some VM running, although I don't know why it would be starting automatically at startup. Running ps aux | grep qemu-system-x86 will give you the full arguments for the process. – saiarcot895 Dec 24 '14 at 1:31
  • the result of that command is that paste.ubuntu.com/9625324 – Riccardo Magrini Dec 26 '14 at 18:31
  • There's a VM named CanonicalDistibution running, with a storage file at /home/d4rkn3t/VStorage/CanonicalDistibution.img. You can install the virt-manager to get a GUI (Virtual Machine Manager) so that you can stop or delete the VM. – saiarcot895 Dec 26 '14 at 20:59
  • VM already run on virtual-manager. I don't understand why in my old PC I never saw virt-manager token 100% of ram, while in new one the result is that? – Riccardo Magrini Dec 28 '14 at 19:20
  • Don't know about that. Is it possible you used some special ISO in installing Ubuntu in the new laptop? – saiarcot895 Dec 29 '14 at 4:53
3

Have you tried to make sure you use the proper accelaration for qemu?
Such as:

qemu-system-x86_64  -machine accel=kvm [...]  

This switch could make your computer use hardware virtualization
(cpu usage drops to negligible then)

-5

I've resolved that modify an option on BIOS,after that now CPU uses just 20%.

  • 8
    hi, can you tell us what did you modify on bios? – Adam Jun 6 '15 at 11:18
  • 1
    Would you provide some details? – Amir Dec 14 '15 at 17:39
  • this does not provide a response to the question. can you give more details ? – skonsoft Jan 24 '17 at 19:56
  • 1
    What did you change? – Mateusz Piotrowski Apr 11 '17 at 14:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.