8

After resuming from suspend, the Network Manager detects my WiFi signal, but eventually gives up when trying to connect to it.

These fixes did not work:

$ sudo restart network-manager
$ sudo nmcli nm sleep false
$ sudo bash -c 'echo SUSPEND_MODULES=\"iwlwifi\" > /etc/pm/config.d/config'

Below are outputs of dmesg | tail -30 in three situations.

When laptop is turned on, WiFi is connected and working.

$ dmesg | tail -30
[    6.479195] nouveau  [     CLK][0000:01:00.0] 0f: core 270-835 MHz memory 2000 MHz 
[    6.479339] nouveau  [     CLK][0000:01:00.0] --: core 405 MHz memory 324 MHz 
[    6.511984] vga_switcheroo: enabled
[    6.512140] [TTM] Zone  kernel: Available graphics memory: 4034782 kiB
[    6.512142] [TTM] Zone   dma32: Available graphics memory: 2097152 kiB
[    6.512143] [TTM] Initializing pool allocator
[    6.512146] [TTM] Initializing DMA pool allocator
[    6.512154] nouveau  [     DRM] VRAM: 2048 MiB
[    6.512155] nouveau  [     DRM] GART: 1048576 MiB
[    6.512159] nouveau  [     DRM] TMDS table version 2.0
[    6.512160] nouveau  [     DRM] DCB version 4.0
[    6.512162] nouveau  [     DRM] DCB outp 00: 02010300 00000000
[    6.512164] nouveau  [     DRM] DCB conn 00: 00000400
[    6.513365] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
[    6.513366] [drm] No driver support for vblank timestamp query.
[    6.513376] nouveau  [     DRM] ACPI backlight interface available, not registering our own
[    6.524228] nouveau  [     DRM] MM: using COPY for buffer copies
[    6.534906] nouveau 0000:01:00.0: No connectors reported connected with modes
[    6.534907] [drm] Cannot find any crtc or sizes - going 1024x768
[    6.565439] nouveau  [     DRM] allocated 1024x768 fb: 0x80000, bo ffff880252922800
[    6.565572] nouveau 0000:01:00.0: fb1: nouveaufb frame buffer device
[    6.565597] [drm] Initialized nouveau 1.1.2 20120801 for 0000:01:00.0 on minor 1
[    6.867191] init: plymouth-upstart-bridge main process ended, respawning
[    6.871109] init: plymouth-upstart-bridge main process ended, respawning
[   14.819661] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131115/nsarguments-95)
[   14.819773] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131115/nsarguments-95)
[   34.230079] audit_printk_skb: 153 callbacks suppressed
[   34.230081] type=1400 audit(1420504569.736:62): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="/usr/lib/cups/backend/cups-pdf" pid=2606 comm="apparmor_parser"
[   34.230086] type=1400 audit(1420504569.736:63): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="/usr/sbin/cupsd" pid=2606 comm="apparmor_parser"
[   34.230384] type=1400 audit(1420504569.736:64): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="/usr/sbin/cupsd" pid=2606 comm="apparmor_parser"

Right after resuming from suspend, when Network Manager is trying to connect. WiFi icon is flashing.

$ dmesg | tail -30
[ 5835.278403] wlan0: authenticated
[ 5835.281414] wlan0: associate with 20:aa:4b:71:61:ef (try 1/3)
[ 5835.389401] wlan0: associate with 20:aa:4b:71:61:ef (try 2/3)
[ 5835.429510] wlan0: associate with 20:aa:4b:71:61:ef (try 3/3)
[ 5835.463202] wlan0: association with 20:aa:4b:71:61:ef timed out
[ 5835.981063] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131115/nsarguments-95)
[ 5835.981273] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131115/nsarguments-95)
[ 5836.451345] wlan0: authenticate with 20:aa:4b:71:61:ef
[ 5836.455839] wlan0: send auth to 20:aa:4b:71:61:ef (try 1/3)
[ 5836.458444] wlan0: authenticated
[ 5836.460831] wlan0: associate with 20:aa:4b:71:61:ef (try 1/3)
[ 5836.568785] wlan0: associate with 20:aa:4b:71:61:ef (try 2/3)
[ 5836.571480] wlan0: RX AssocResp from 20:aa:4b:71:61:ef (capab=0x411 status=1 aid=5)
[ 5836.571487] wlan0: 20:aa:4b:71:61:ef denied association (code=1)
[ 5837.236668] wlan0: deauthenticating from 20:aa:4b:71:61:ef by local choice (reason=3)
[ 5838.717178] wlan0: authenticate with 20:aa:4b:71:61:ef
[ 5838.721191] wlan0: send auth to 20:aa:4b:71:61:ef (try 1/3)
[ 5838.723777] wlan0: authenticated
[ 5838.727683] wlan0: associate with 20:aa:4b:71:61:ef (try 1/3)
[ 5838.751269] wlan0: RX AssocResp from 20:aa:4b:71:61:ef (capab=0x411 status=0 aid=5)
[ 5838.755381] wlan0: associated
[ 5841.893920] wlan0: deauthenticated from 20:aa:4b:71:61:ef (Reason: 2)
[ 5841.901569] cfg80211: Calling CRDA to update world regulatory domain
[ 5841.906314] cfg80211: World regulatory domain updated:
[ 5841.906319] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 5841.906323] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 5841.906326] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 5841.906328] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 5841.906330] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 5841.906333] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)

A minute or so after the above state, it stops trying to connect. WiFi icon is empty. A notification pops up saying "Disconnected - you are now offline".

$ dmesg | tail -30
[ 5932.449208] wlan0: authenticate with 20:aa:4b:71:61:ef
[ 5932.452768] wlan0: send auth to 20:aa:4b:71:61:ef (try 1/3)
[ 5932.455454] wlan0: authenticated
[ 5932.456978] wlan0: associate with 20:aa:4b:71:61:ef (try 1/3)
[ 5932.480497] wlan0: RX AssocResp from 20:aa:4b:71:61:ef (capab=0x411 status=0 aid=5)
[ 5932.484791] wlan0: associated
[ 5935.611797] wlan0: deauthenticated from 20:aa:4b:71:61:ef (Reason: 2)
[ 5935.625479] cfg80211: Calling CRDA to update world regulatory domain
[ 5935.630150] cfg80211: World regulatory domain updated:
[ 5935.630156] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 5935.630159] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 5935.630162] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 5935.630164] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 5935.630167] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 5935.630169] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 5947.144676] wlan0: authenticate with 20:aa:4b:71:61:ef
[ 5947.148096] wlan0: send auth to 20:aa:4b:71:61:ef (try 1/3)
[ 5947.150573] wlan0: authenticated
[ 5947.153610] wlan0: associate with 20:aa:4b:71:61:ef (try 1/3)
[ 5947.177143] wlan0: RX AssocResp from 20:aa:4b:71:61:ef (capab=0x411 status=0 aid=5)
[ 5947.181446] wlan0: associated
[ 5950.313613] wlan0: deauthenticated from 20:aa:4b:71:61:ef (Reason: 2)
[ 5950.323551] cfg80211: Calling CRDA to update world regulatory domain
[ 5950.328210] cfg80211: World regulatory domain updated:
[ 5950.328215] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 5950.328219] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 5950.328221] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 5950.328224] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 5950.328226] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 5950.328228] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
2
  • After going through suspend and failing to connect, what does this command in terminal tell dmesg | tail -30 – Jeremy31 Jan 1 '15 at 15:33
  • @Jeremy31 I added output of dmesg | tail -30 in different three situations – onepiece Jan 6 '15 at 0:48
5
+50

From ubuntuforums:

Type these lines of code in the terminal one at a time:

sudo touch /etc/pm/sleep.d/wakenet.sh
sudo chmod +x /etc/pm/sleep.d/wakenet.sh
sudo gedit /etc/pm/sleep.d/wakenet.sh

Then in the Gedit window that opens up, copy paste this text and press save.

#!/bin/bash
case "$1" in
thaw|resume)
sudo nmcli nm sleep false
sudo pkill -f wpa_supplicant
;;
*)
;;
esac
exit $?

Hope that helps.

4
  • Unfortunately, this didn't work. – onepiece Dec 29 '14 at 21:07
  • Even after rebooting? – Parto Dec 30 '14 at 5:45
  • I tried this modification and it solved the issue: add sudo before nmcli nm sleep false and pkill -f wpa_supplicant. – onepiece Jan 3 '15 at 9:34
  • Cool. Let me edit the answer and include that. – Parto Jan 3 '15 at 9:48
2

Try the below command and restart the network manager,

sudo service dbus restart

sudo service network-manager restart
2
  • sudo service dbus restart turned my screen black and my cursor into a black "X" with a white outline – onepiece Dec 23 '14 at 8:02
  • Running the second command (sudo service network-manager restart) fixed it for me – Matt G Mar 28 '17 at 21:09
1

I don’t know about programming but i had this issue and to make it work I just needed to unchecked the automatically connect to this network when available box , and check the allow all users to connect to this network box all this is in the network connections--> edit connections --> general

0
0

It might be an issue with your wifi firmware. Here's an answer to a similiar question that might help you:

Download the brcmfmac43602 firmware from the Linux firmware git repo

Copy it to /lib/firmware/brcm

Reboot and enjoy your WiFi.

I tried it on a MacBook Pro 12,1 and it helped resolve this issue (as well as an issue with WPA2 networks)

Not the answer you're looking for? Browse other questions tagged or ask your own question.