How can I enable autologin on lubuntu 14.10? I tried various method like this LXDE Auto Login but they don't work.

  • 1
    Did you encrypt your home folder when you installed Ubuntu? If so, autologin is disabled to protect the encrypted home folder. – user68186 Dec 22 '14 at 20:46

According to the Lubuntu Wiki https://help.ubuntu.com/community/Lubuntu/Boot_Install_Login#For_release_12.04_and_on_.28LightDM.29

you must

For release 12.04 and on (LightDM)

You will need to create an /etc/lightdm/lightdm.conf with these contents: (do this as root)

[SeatDefaults]

autologin-user=<YOUR USER>

autologin-user-timeout=0

user-session=Lubuntu

greeter-session=lightdm-gtk-greeter

It appears that what you have tried and say does not work is similar but not the same as this solution.

  • 2
    A comment on htpcbeginner.com/enable-lubuntu-auto-login says From lubuntu 14.04, you should use this file /etc/lightdm/lightdm.conf.d/20-lubuntu.conf for the seatdefaults, the syntax is the same. Turns out he's right. At least for me anyway. – AaronD Mar 1 '16 at 21:33

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.