2

Anyone tell me why I getting this error, when I trying to connect my sftp through filezilla.

Response:   fzSftp started
Command:    keyfile "/home/supravat/.ssh/pub_key"
Command:    open "54969b2f4382ecdffa0000f5@developer-ecommarce.rhcloud.com" 22
*Error: Pageant failed to answer challenge*
*Error: Could not connect to server*

How to solve this error?

14

This happened to me. What I did to fix it was:

echo $SSH_AUTH_SOCK

to find out what the path is. This will return something like /home/user/.cache/keyring-XXXXXX/ssh or /run/user/1000/keyring/ssh. Then just rename the file:

mv "$SSH_AUTH_SOCK" "$SSH_AUTH_SOCKrem"

I was able to login after that.

3
  • I got this error with putty and this solved the problem as well.
    – LinuxLuigi
    May 27 '18 at 16:02
  • This fixed the issue for me but disabled the ubuntu keyring. So I had to type my ssh password each time i used it (e.g.: each git push ..). So after i ran my sftp program (filezilla, in my case) and used it, I just did the reverse mv to restore the ubuntu keyering working. Also note i had to do the mv on the actual file ( mv /run/user/1000/keyring/ssh /run/user/1000/keyring/sshrem and then later mv /run/user/1000/keyring/sshrem /run/user/1000/keyring/ssh)
    – yuvilio
    Sep 20 '18 at 17:09
  • This worked for me!! Dec 5 '18 at 8:55
1

In my case key was in .ppk format so I had to install putty:

apt-get install putty

I have also installed putty-tools:

apt-get install putty-tools

And from now, everything has worked as expected in filezilla.

0

I faced the same problem. To fix it, First I restart my device and then run

sudo apt-get update && upgrade 
0

I got this error after attempting to swap my SSH keys in ~/.ssh/id_rsa and ~/.ssh/id_rsa.pub with credentials from a PPK file using a text editor.

After switching the ssh files back to their original content and trying to connect to a saved connection via SFTP, I received the Pageant failed to answer challenge error.


This was solved by simply restarting my machine.

0

I found a fix that worked in my case after doing a backup and reinstalling ubuntu and this issue occurs

chmod 600 ~/.ssh/id_rsa

Source

0

I have faced the same error and it turns out to be a permission error.
I have given permission to my server public and private key as below.

chmod 400 myprivate
chmod 400 mypublic.pub

It is resolved for me with the above steps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.