i set up an ubuntu server in virtual box following these and these instructions.My connection worked,also ssh . Then, i signed up in dyndns.com ,i configured the router ,but in the port forward i changed the 2222 port to 80 because it couldn’t forward from 2222.My port is open and accepting connections but i don’t have any more connection from the server in the virtual box. From virtual box settings->network->port forwarding , i use: Host IP : , Host port :80 , Guest Port :22 ,Guest IP : its empty.

I am not sure if i am using right the address in /etc/network/interfaces , i use and also this address i use for the firewall rules in the router. Also,in the server /etc/resolv.conf i put that address and in /etc/mysql/my.cnf.

I can ping that address but nothing more.(of course neither ssh works)

Thank you

2 Answers 2


I would change your network connection settings ("Devices" -> "Network Adapters...") from NAT to "Bridged Adapter". You will want your virtual box to get an IP Address from your router and not a separate one from the host machine.

VirtualBox Network settings tab showing attached to, bridged adapter

This should allow you to use only the router's configuration to poke a port directly to your virtual box on the network.

  • When you say strait,you mean from the settings choose instead of nat "not attached"?I tried but still the same
    – George
    Aug 9, 2011 at 12:04
  • I mean "Bridged", I've added a screenshot to show you the kind of options available in VirtualBox OSE. Aug 9, 2011 at 12:21
  • It gives me"Failed to open a session for the virtual machine UbuntuServer. Unknown configuration node '//ssh' found in the configuration of IntNet instance #0 (VERR_CFGM_CONFIG_UNKNOWN_NODE). Unknown error creating VM (VERR_CFGM_CONFIG_UNKNOWN_NODE)."Also, i am not sure if i want nat or bridge.Thanks
    – George
    Aug 9, 2011 at 12:43
  • That error is very scary, you may need to report a bug. Aug 16, 2011 at 18:54

You mentioned that you changed your forwarding port from 2222 to 80. According to VirtualBox in their description of NAT Limitations that won't work:


Forwarding host ports < 1024 impossible:

On Unix-based hosts (e.g. Linux, Solaris, Mac OS X) it is not possible to bind to ports below 1024 from applications that are not run by root. As a result, if you try to configure such a port forwarding, the VM will refuse to start.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.