1

I've tried to create a symbolic link from a file in /media/myuser/nameofdevice/myfolderA to the folder /media/myuser/nameofdevice/myfolderB with the command ln but I get an error. Is possible to do it or it is impossible to do? And if I can't, why?

The error is:

ln: failed to create the symbolic link '/media/myuser/nameofdevice/myfolderB/animacion_cgi_theo_jansen.mp4': Operation not permitted

I tried with sudo and without it. I'm in the right folder where file is.

sudo ln -s animacion_cgi_theo_jansen.mp4 /media/myuser/nameofdevice/myfolderB
14
  • but I get an error - the error message is the most important information if you want an answer... – Cornelius Dec 21 '14 at 13:44
  • Should be no problem. Without seeing the command you typed or your error message all I can suggest is using the correct format ln -s source-file symlink. So for example you would use ln -s /media/myuser/nameofdevice/myfolderA/FILENAME.FILETYPE /media/myuser/nameofdevice/myfolderB/ – Tom Brossman Dec 21 '14 at 13:46
  • @Cornelius I have added the error log – Yábir Garcia Dec 21 '14 at 14:06
  • put sudo in front of ls and try again. – Cornelius Dec 21 '14 at 14:07
  • 1
    @YábirGarcia and symlinks are supported by vfat since when? ;-) – Rinzwind Dec 21 '14 at 14:36
1

@Rinzwind Has answered me. The usb mounted was in vfat and It doens't accept symbolic links. So the solution was reformat it to ext4 and now I can create the symbolic links

1
  • Just be aware that other devices will likely not be able to read the new file format. – Paul Dec 21 '14 at 23:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.