4

I have a problem with Firefox and the Flash-player.

My other problems I solved with success with uncle Google and a little bit of Ubuntu magazines. But now I am trying to solve this problem nearly 2 days by myself and I cant get it.

First I used the "Adobe Flash-player" from the Software Centre, what followed is, that it failed to load the "libpepflashplayer.so".

Ok, open your browser and use Google, read one search result, the next and so on. In the end it didn't changed a thing.

Here are my search results: the link

Then I reinstalled it, like in the old days. No change, looking at the Firefox add-on's/extensions --> not listed in the "internal" extension (I think you know what I mean). Downloaded it, restarted computer, to be sure, that It should work, no change.

After that over-thinking the situation I cam to the following conclusion. OK, if Adobe doesn't want to work, I gonna try another flash-player, okay, use Google and it will be fine. Not really. I installed the pepper flash plug-in and what I have now, is that the YouTube videos, for example are played in fast forward.

[can't find the link now, where the commands were]

What do I have to do? Why is this happening? How can it be solved?

I don't think it is necessary to give my system data or? Just to be on the safe side:

  • i5 Ivy Bridge
  • 120GB SSD (enough space)
  • Intel HD 4000

Thank you for taking time, to help me.

Have a nice day.

  • 1
    Youtube workaround: use HTML5 to watch videos. – Xen2050 Dec 21 '14 at 12:23
6

You seemed to have installed the Pepper Flash Plugin.

To make it work for Firefox, enter the following commands -

sudo add-apt-repository ppa:nilarimogard/webupd8
sudo apt-get update
sudo apt-get install freshplayerplugin

If you don't have Google Chrome installed, you may have to run the following -

sudo apt-get install pepperflashplugin-nonfree
sudo update-pepperflashplugin-nonfree --install

However, I would suggest that you use flashplugin-installer instead.

Go to the software center and remove the flash player that you installed.

Now install flash player using the command -

sudo apt-get install flashplugin-installer
1

This is a guess, but I think you need to activate Canonical Partner and then do:

sudo apt-get install --reinstall flashplugin-installer
  • hey, thank you, I have already done, what is in your link, but I think I have to remove the pepper flash-player first. The problem is still here, even after executing your command. – Sparkay Dec 21 '14 at 12:04
0

I believe I understand the problem, to a point, and I, for one, overcame it. By the way, if anyone down-votes this "answer" I'll delete it, and then there will be one fewer post on this site that actually helps people.

I'm a little touchy on this subject because of the two down-votes I received the last time I posted this solution, which you can read behind this link.

I have updated that link just a little bit at the very bottom just now to include a download link which will permit you to install the version of the Chrome Browser which currently appears to work best for videos of the type one finds on Youtube, and apparently most everywhere else currently.

  • Thank you for the answer. I have tried not only Firefox. I used Chrome on Windows, and I knew about Chromium. With my google-acc it would be much easier to switch to ubuntu. But somehow, Chromium, never wanted to login, with my google account. Thereafter I tested Chrome, int freezed and I had to force it to close. As I understand you, in your answer in the other read, you want me to change another browser, especially Chrome in this case. I gonna work to try to get this work, as a beginner it may take a while, to get it working like it has to work. – Sparkay Dec 21 '14 at 12:19
  • I confess that I have not yet upgraded any of my 12.04 systems to 14.04, but reading as many complaints as I see on this site, I'm hesitant to do so. I suppose I should if only so I can try to understand and solve them. – gyropyge Dec 21 '14 at 21:08
0

I had the same problem. Stumped also. That is, until realized the problem was getting the .so file in the right place. This is what worked for me:

First, download plugin from adobe: libflashplayer.so

Unpack into Home folder or other simple to find place.

Then, in terminal, start file browser as root:

sudo nautilus

Finally in the new file browser window copy and paste the file libflashplayer.so from where it was unpacked into computer/usr/lib/firefox-addons/plugins

Close the file manager and terminal.

Restart Firefox.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.