1

I just installed new fglrx drivers on Ubuntu 14.04. New AMD drivers are distribution-specific, so downloaded them. Since it says they re compatible with kernel up to 3.17 version on release notes, downloaded kernel 3.17.6 version and dpkg -i'ed it. While installing, there it says there is errors. This is the log.

So, restart computer and after log in, computer freezes. Lucky thing i can reboot, access recovery mode and select between kernels (default version on trusty is 3.13.*).

Then, I tried installing a kernel "between" 3.13 and 3.17; installed 3.15.10 and everything went fine. Tried then 3.17.0 (stable), wrong again. So I stayed on 3.16.7 and everything fine.

Anyone knows what happened with 3.17 and how to solve it? I suspect AMD meant 3.16 on release notes instead 3.16... oh, almost forgot. Here is the log of error when dpkg kernel. Is a fglrx log, same for any 3.17.*:

DKMS make.log for fglrx-core-14.501 for kernel 3.17.4-031704-generic (x86_64)
dom dic 21 03:55:11 CLST 2014
/usr/sbin/dkms: línea 73: cd: /var/lib/dkms/fglrx/14.501/build: No existe el archivo o el directorio
AMD kernel module generator version 2.1
doing Makefile based build for kernel 2.6.x and higher
rm -rf *.c *.h *.o *.ko *.a .??* *.symvers
make -C /lib/modules/3.17.4-031704-generic/build SUBDIRS=/var/lib/dkms/fglrx-core/14.501/build/2.6.x modules
make[1]: se ingresa al directorio «/usr/src/linux-headers-3.17.4-031704-generic»
  CC [M]  /var/lib/dkms/fglrx-core/14.501/build/2.6.x/firegl_public.o
/var/lib/dkms/fglrx-core/14.501/build/2.6.x/firegl_public.c:6396:12: warning: ‘KCL_fpu_save_init’ defined but not used [-Wunused-function]
 static int KCL_fpu_save_init(struct task_struct *tsk)
            ^
  CC [M]  /var/lib/dkms/fglrx-core/14.501/build/2.6.x/kcl_acpi.o
/var/lib/dkms/fglrx-core/14.501/build/2.6.x/kcl_acpi.c: In function ‘KCL_ACPI_Slot_No_Hotplug’:
/var/lib/dkms/fglrx-core/14.501/build/2.6.x/kcl_acpi.c:845:21: error: ‘struct acpi_device_flags’ has no member named ‘no_hotplug’
          tdev->flags.no_hotplug = true;
                     ^
make[2 ]: *** [/var/lib/dkms/fglrx-core/14.501/build/2.6.x/kcl_acpi.o] Error 1
make[1 ]: *** [_module_/var/lib/dkms/fglrx-core/14.501/build/2.6.x] Error 2
make[1 ]: se sale del directorio «/usr/src/linux-headers-3.17.4-031704-generic»
make: *** [kmod_build] Error 2
build failed with return value 2
1

Actually, there is a patch for fglrx 14.501 to make it working with the kernel 3.17.X (source). Since I wanted to install from debs I did it a bit different way, than described in the linked source.

  1. Download deb packages from AMD site
  2. Extract the fglrx_core dpkg-deb -R packagename.deb tmp
  3. Apply patch to file tmp/usr/src/fglrx-core-14.501/kcl_acpi.c (I have just added the missing lines manually)
  4. Rename/remove old deb package
  5. Rebuild package dpkg-deb -b tmp packagename.deb
  6. Install from fixed deb
|improve this answer|||||
  • I didn't noticed your answer, I'm gonna check this. Thanks! :) – zx_k9 May 4 '15 at 3:16
1

AMD only support up to Kernel 3.16. No support for Kernel 3.17 and > yet

|improve this answer|||||
  • 2
    Omega Driver's Install notes says: "up to 3.17", after that kernel desnt'n work. No support Sorry :( – Azahel M Tovar Jan 25 '15 at 16:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.