5

I installed the xrdp on the ubuntu 14.04 desktop and I followed instructions in Blank desktop when logging in via xrdp, http://ubuntuforums.org/showthread.php?t=1899111&page=2 and https://bugs.launchpad.net/ubuntu/+source/xrdp/+bug/1069272, but after I successfully log in from Windows 7 remote desktop, the screen is:

enter image description here

Any idea? Thanks a lot.

PS: Let's restrict the question to Windows's remote desktop + xrdp on the ubuntu 14.04.

2

It is a bug of xrdp when using it to connect to ubuntu 14.04. See here. The only thing we can do about it now is to wait until xrdp developers show some mercy by starting to think of fixing this bug. Please help me by clicking "this bug affects you" and "subscribe this bug" link of the above launchpad page to increase the bug heat. Thanks.

  • In the meantime, you could try a different desktop, like xfce, which seems to work with xrdp. – obsolesced Aug 25 '16 at 4:23
1

Just xrdp gives your RDC just what is it there, bare X server. To see "desktop", menus, icons etc you need to have some windows manager / desktop environment installed and started. Please elaborate which of them did you install.

The proper way is to edit X startup configuration files -- there are plenty, change often so I can't answer what is file name without your help. For example, my server with xrdp has ~/.xsession file containing xfce4-session and ~/.xinitrc-fvwm has

xsetroot -solid "#0E6E6E"
xset s 600 600 s blank
xset -dpms

As a workaround for 1 particular time I am connecting via ssh and start startx &, this does the rest of magic (menus, panels, icons appear).

  • I installed package "ubuntu-desktop". The contents of ~/.xsession file is gnome-session --session=ubuntu-2d. Where do you run startx &? Do you put it in the ~/.xsession file? – user280121 Dec 22 '14 at 6:26
  • So xrdp cannot show unity 3d (with just RDP) and you tried ubuntu 2d. In the launchpad bug 1069272 they say "Ubuntu has removed unity 2d support in 12.10". So I suggest to try echo "gnome-session --session=gnome" > ~/.xsession 2nd option is to use VNC; you select vnc-any, xrdp internally connects to it then convert its output to RDP (yes that's not optimal). – Vladimir Kovalchuk Dec 23 '14 at 11:02
  • Changing to "gnome-session --session=gnome" does not work. What do you mean by "you select vnc-any"? – user280121 Dec 23 '14 at 13:29
  • I meant during login the user should select "vnc-any" from the drop-down of possible modes that xrdp knows about. Sorry if that does not make sense to you, that piece of software is a bit too complicated. BTW I am also sorry to not being explicit you had to install gnome-fallback-session package. Just specifying desired DE without actually installing it isnt going to work. – Vladimir Kovalchuk Dec 23 '14 at 21:07
  • Thanks. do you mean gnome-session-fallback? I installed it, but does not work. It turns out that it is a bug of xrdp on ubuntu 14.04 which is the version I am using. The only way out is to wait for xrdp developers to show some mercy by fixing this bug. – user280121 Dec 24 '14 at 3:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.