6

I was unable to setup nut on a server for the UPS Eaton 5E with USB connection. All results what did I get was that driver is not running and UPS is not recognized. What kind of driver is suitable for me and what kind of settings? Unit is Eaton 5E.

result of $ lsusb -v

Bus 004 Device 007: ID 0463:ffff MGE UPS Systems UPS
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               1.10
  bDeviceClass            0 (Defined at Interface level)
  bDeviceSubClass         0 
  bDeviceProtocol         0 
  bMaxPacketSize0         8
  idVendor           0x0463 MGE UPS Systems
  idProduct          0xffff UPS
  bcdDevice            0.01
  iManufacturer           1 
  iProduct                2 
  iSerial                 0 
  bNumConfigurations      1
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength           34
    bNumInterfaces          1
    bConfigurationValue     1
    iConfiguration          0 
    bmAttributes         0xa0
      (Bus Powered)
      Remote Wakeup
    MaxPower               20mA
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           1
      bInterfaceClass         3 Human Interface Device
      bInterfaceSubClass      0 No Subclass
      bInterfaceProtocol      0 None
      iInterface              0 
        HID Device Descriptor:
          bLength                 9
          bDescriptorType        33
          bcdHID               1.10
          bCountryCode           33 US
          bNumDescriptors         1
          bDescriptorType        34 Report
          wDescriptorLength     549
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x81  EP 1 IN
        bmAttributes            3
          Transfer Type            Interrupt
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0008  1x 8 bytes
        bInterval              20
Device Status:     0x0001
  Self Powered

Content of /etc/nut/ups.conf

[Eaton5E]
driver = blazer_usb
port = auto

Result of $ upsdrvctl start for usbhid-ups driver:

Network UPS Tools - UPS driver controller 2.4.3
Network UPS Tools - Generic HID driver 0.34 (2.4.3)
USB communication driver 0.31
No matching HID UPS found
Driver failed to start (exit status=1)

Result of $ upsdrvctl start for blazer_usb driver:

Network UPS Tools - UPS driver controller 2.4.3
Network UPS Tools - Megatec/Q1 protocol USB driver 0.03 (2.4.3)
No supported devices found. Please check your device availability with 'lsusb'
and make sure you have an up-to-date version of NUT. If this does not help,
try running the driver with at least 'subdriver', 'vendorid' and 'productid'
options specified. Please refer to the man page for details about these options
(man 8 blazer).

Driver failed to start (exit status=1)

Update: I tried to connect a desktop linux Xubuntu 12.04, which detected the UPS and UPS vendor via usbhid-ups driver, but did not detected any battery state and shows battery as discharged (what is not true, server is running on it several minutes with no troubles) and fiel technology as Unknown.

4

Try to use the config from this blogger: http://risc-a-day.blogspot.hu/2014/09/getting-my-ups-to-work-with-linux.html

(Excerpts:

lsusb
...
Bus 008 Device 002: ID 0463:ffff MGE UPS Systems UPS

... edit /etc/nut/ups.conf and add section for the UPS device itself:

...

[myups]
    driver = usbhid-ups
    port = auto
    vendorid = 0463
    pollfreq = 30

...

$ sudo upsdrvctl start

...

$ upsc myups

battery.charge: 75
battery.runtime: 1737
battery.type: PbAc
device.mfr: EATON
device.model: 5E 1100i
device.type: ups
driver.name: usbhid-ups
driver.parameter.pollfreq: 30
driver.parameter.pollinterval: 2
driver.parameter.port: auto
driver.parameter.vendorid: 0463
driver.version: 2.6.4
driver.version.data: MGE HID 1.31
driver.version.internal: 0.37
input.voltage: 229.0
outlet.1.status: on
outlet.desc: Main Outlet
outlet.id: 1
outlet.switchable: no
output.frequency: 49.9
output.frequency.nominal: 50
output.voltage: 233.0
output.voltage.nominal: 230
ups.beeper.status: enabled
ups.delay.shutdown: 20
ups.firmware: 01.04.0018
ups.load: 12
ups.mfr: EATON
ups.model: 5E 1100i
ups.power.nominal: 1100
ups.productid: ffff
ups.start.battery: yes
ups.status: OL CHRG
ups.timer.shutdown: -1
ups.vendorid: 0463

)

| improve this answer | |
  • 2
    Although your answer is 100% correct, it might also become 100% useless if that link is moved, changed, merged into another one or the main site just disappears... :-( Therefore, please edit your answer, and copy the relevant steps from the link into your answer, thereby guaranteeing your answer for 100% of the lifetime of this site! ;-) You can always leave the link in at the bottom of your answer as a source for your material... – Fabby Oct 8 '15 at 15:11
  • looks promising, finally on 5E, will try it asap. – Dee Oct 9 '15 at 13:27
1

once try these things,

You can use lsusb to find out the bus and device number

Then change permission to the device

        chmod 0666 /dev/bus/usb/[bus number]/[device number]

as for details go with rouble starting Network UPS Tools with a Eaton 3S UPS

| improve this answer | |
  • Originally I had security issue, but I managed to use 0660 by etc/udev/rules.d, adding a file with rule: ACTION=="add", SUBSYSTEM=="usb", ATTR{idVendor}=="0463", ATTR{idProduct}=="ffff", MODE="0660", GROUP="nut", where vendor and product comply with result of lsusb. I did try your chmod method with no error, but upsdrvctl start beaves the same. – Dee Dec 23 '14 at 13:45
  • And same: By the way, there is an Eaton 5E, not 3S – Dee Dec 30 '14 at 16:22
  • This complements Grin's solution. It is necessary to put the device file as 666 after configuring nut. Perfect, dude. Saved my life ;)! Thanks. – ivanleoncz Nov 16 '18 at 17:26
0

According to page Configuring NUT for the Eaton 3S UPS on Ubuntu Linux you should use driver usbhid-ups rather than blazer_usb in /etc/nut/ups.conf. Also make sure you have MODE=standalone in /etc/nut/nut.conf.

| improve this answer | |
  • mode is 'standalone'. I did try option 'netserver' as well without any result. I tried usbhid-ups driver with no result as is described in my initial text. – Dee Dec 23 '14 at 13:38
  • By the way, there is an Eaton 5E, not 3S – Dee Dec 28 '14 at 6:14
0

if you have security issue do like #Dee
1. in etc/udev/rules.d, adding a file '90-nut-eaton.rules':

ACTION=="add", SUBSYSTEM=="usb", ATTR{idVendor}=="0463", ATTR{idProduct}=="ffff", MODE="0660", GROUP="nut",

  1. Don't forget unplug yours usb devices and plug it again!! Rules must go :) because their apply on newly detected devices (after change rules.d) by the system.
| improve this answer | |
0

It might be worthwhile checking the cables also. Had exactly the same issue on two Eaton 5E units which was fixed by switching to shorter USB cables. Also usbhid-ups is the right driver for Eaton 5E.

Related EATON/MGE 5E UPS - driver not working

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.