I installed Ubuntu 12.04 on an Acer e5-571-31KM. Dmesg and lspci output indicate a wireless Network adapter was found, but according to ifconfig there is no wlan0 interface. Unfortunately I have no access to the machine right now, so I can't post the exact output, but I remember lspci gave me:

Network Controller: Intel Corporation Wireless 3160 (rev 83)

rfkill indicates that the wireless adapter is neither hard, nor soft blocked.

What I've tried so far:
- Reinstalling linux-firmware-nonfree
- installing the iwlwifi driver manually from this site 'http://wireless.kernel.org/en/users/Drivers/iwlwifi'

Both attempts didn't have any effect.

I'll have access to the computer this evening, so I will be able to post kernel version and exact outputs.

Do you have any ideas what to do?

Edit 1:

Here is lspci output:

00:00.0 Host bridge: Intel Corporation Haswell-ULT DRAM Controller (rev 0b)
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics     Controller (rev 0b)
00:03.0 Audio device: Intel Corporation Device 0a0c (rev 0b)
00:14.0 USB controller: Intel Corporation Lynx Point-LP USB xHCI HC (rev 04)
00:16.0 Communication controller: Intel Corporation Lynx Point-LP HECI #0 (rev 04)
00:1b.0 Audio device: Intel Corporation Lynx Point-LP HD Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation Lynx Point-LP PCI Express Root Port 3 (rev e4)
00:1c.3 PCI bridge: Intel Corporation Lynx Point-LP PCI Express Root Port 4 (rev e4)
00:1d.0 USB controller: Intel Corporation Lynx Point-LP USB EHCI #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation Lynx Point-LP LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation Lynx Point-LP SATA Controller 1 [AHCI     mode] (rev 04)
00:1f.3 SMBus: Intel Corporation Lynx Point-LP SMBus Controller (rev 04)
01:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. Device 5287 (rev 01)
01:00.1 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI     Express Gigabit Ethernet Controller (rev 12)
02:00.0 Network controller: Intel Corporation Wireless 3160 (rev 83)

uname -r gives:



lo        no wireless extensions.

eth0      no wireless extensions.    
  • maybe ifconfig is in conflict with NetworkManager? try to install and use wpasupplicant – LittleByBlue Dec 20 '14 at 14:03
  • Thanks for the advice, I don't know exactly what you mean, but I'll give it a try asap. The wlan0 interface didn't show up in the gui, nor in iwconfig, etc. , if this is of any help. – schrankwand55 Dec 20 '14 at 16:11

I suspect that your relatively new device is not covered in the relatively old 12.04 kernel. I suggest you get a temporary internet connection. Open a terminal and run:

uname -r

Is your kernel version annotated '-pae'? If so, please do:

sudo apt-get install linux-backports-modules-cw-3.10-precise-generic-pae

If not, do:

sudo apt-get install linux-backports-modules-cw-3.10-precise-generic

Detach the ethernet and reboot. Your wireless should now be working.

  • Thank you very much for your help. I'll try it as soon as I have access to the mentioned machine (probably in 2 to 5 hours). What is the difference between the -pae and non -pae version? I read this advice in some other forum and tried it yesterday, but without any success. I didn't know the difference betwean -pae and the other version and simply installed some pae version. Do I have to reinstall the whole system in order to get back to the original kernel? And after I installed the new kernel do I have to change something in Grub in order to boot with the new kernel? Thank you very much ! – schrankwand55 Dec 20 '14 at 16:06
  • PS: @chili555 I found an article concerning Physical Address Extension in Wikipedia. As the CPU supports 64bit, from my understanding (based on Wikipedia) there is thus no need for pae. I'll have access to the machine in 5 minutes, is there anything else (info) you need? – schrankwand55 Dec 20 '14 at 16:21
  • @schrankwand55 Nope. Please proceed. – chili555 Dec 20 '14 at 16:49
  • Thank you very much! Installing the updated kernel worked for me. Keep up the good work, it's people like you who help to spread freedom. Thank you. – schrankwand55 Dec 20 '14 at 17:26
  • How can I mark the question as solved? It says I have to use a flag but flag gives me only the option to ask for a moderators attention? Thank you again! @chili555 – schrankwand55 Dec 20 '14 at 17:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.