0

:)

Lately, I have been trying to share my internet to my android tab(Samsung Galaxy tab 2, 10.1) via Wifi hotspot.

What I did:

I have used KDE network manager to create a wifi(shared) profile with WPA/WPA2 encryption security. Then, I have connected to that network using "Connect to hidden wifi networks", and it showed that it has been connected.

What is happening:

But, when I am looking for that hotspot using my android tab, the device is not finding the wifi network.

Any help in this regard would be appreciated. Thank you. :)

Information used: (http://ubuntuhandbook.org/index.php/2014/06/share-internet-with-android-ubuntu-1404/) PS: I am a fresh Ubuntu(linux) OS user :)

0

I've been using this method for a while to share between 3 android devices (Nexus 7 , Nexus 9 and Desire 816) as well as the odd laptop and it works without a hitch on Ubuntu 14.10 using unity.

I think the main difference and the only change you may need to make is changing the connection type to ap as described in the guide i linked.

10
  • Hi, thanks for replying. I have followed this tutorial. :/ steps I followed, i) turned off the wifi, created a wifi profile, ii) edited that file, set the variable as mode=ap, then I have connected to the network using "Connect to hidden wifi network", but my android device can't find the hotspot. :( – Skynet094 Dec 20 '14 at 9:13
  • No worries , my other suggestion is trying an app called ap-hotspot it has worked for me in the past – MuffinStateWide Dec 20 '14 at 9:16
  • Thanks again, I have tried ap-hotspot , I used this link:askubuntu.com/questions/453877/… , it worked somewhat, I could find the wifi hotspot channel using my tab, but each time I tried to connect, it shows authentication error( I am sure I am typing the password correctly). :/ – Skynet094 Dec 20 '14 at 9:19
  • do you have hostapd, dnsmasqand bridge-utils installed? I think dnsmasq and burdge-utilshandle the authentication and address leasing stuff – MuffinStateWide Dec 20 '14 at 9:21
  • my bad , its supposed to say bridge-utils . i cant change it yet – MuffinStateWide Dec 20 '14 at 9:30
0

Yes it does.

I used this post and it worked finally!

http://codewriteup.blogspot.com/2014/08/tested-working-set-up-wifi-hotspot-on.html

One note: Delete the prior installation of ap-hotspot if applicable!

1
  • @ MuffinStateWide, finally I found a solution! :) – Skynet094 Dec 24 '14 at 6:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.