1

I had this Ubuntu infinite login loop problem, and after searching the forum, I did these steps.

Ctrl + Alt + F6

ls -lah

I found -rw------- 1 root root 20 Dec .Xauthority

So I did chown username:username .Xauthority as mentioned by someone in the forums.

After this I tried to login from my user, and it worked, but now I'm facing a new problem, that is, the Launcher and Panel are missing. Did I do anything wrong ?

Further I did

dconf reset -f /org/compiz/

But it gave an error

error: cannot autolaunch D-Bus without X11 $DISPLAY

How do I solve this problem?

  • Please post an answer if you have solved it, instead of editing the question. – muru Dec 21 '14 at 9:50
  • I've just discovered that I can answer my own question ! so, did as you suggested. Hope it would be helpful for others too facing similar problem. – kaspa Dec 22 '14 at 14:18
2

Finally, I solved this problem, though I'm not sure which one below solved the problem, since I tried both steps successively.

Try 1:

Ctrl+Alt+F1

sudo apt-get install compizconfig-settings-manager
export DISPLAY=:0
ccsm

Try 2:

dconf reset -f /org/compiz
unity --reset-icons &disown

To get back to the login screen

service lightdm restart
  • Thank you! I've tried every solution to this on the whole Internet and this fixed it for me: unity --reset-icons &disown – Ludo Sep 12 '16 at 19:34
0

I would not suggest that you did something wrong. I encountered the same issue with unity through installing updates.

it seems the fix is to run

dconf reset -f /org/compiz/

which resets the compiz profiles and plugins associated with unity.

after the command you could reboot or simply restart lightdm (sudo service lightdm restart)and log back in.

Second Solution

It may be worth adding export DISPLAY=:0 to the command which would make my first suggestion change to export DISPLAY=:0 && dconf reset -f /org/compiz/

Alternatively you could log in then swap to a tty (crtl+alt+F1)and send a terminal to the desktop, which can be achieved by export DISPLAY=:0 && gnome-terminal then hitting ctrl+alt+f7 to get back to the GUI and then try executing dconf reset -f /org/compiz/ from the terminal that should be on your unity-less desktop.

sorry if this is confusing , but im not sure how else to get around your error

  • I tried as you said, but as I typed the first command, it throws an error error: cannot autolaunch D-Bus without X11 $DISPLAY – kaspa Dec 20 '14 at 8:44
  • I'm not sure how much more help i can be , but would you mind adding the error to your question ? somebody else may know what to do – MuffinStateWide Dec 20 '14 at 8:51
  • ive added a second solution , sorry again if its confusing – MuffinStateWide Dec 20 '14 at 9:15

Not the answer you're looking for? Browse other questions tagged or ask your own question.