0

I have a problem with my laptop asus S551LB with Ubuntu 14.04

when I initialize Ubuntu, appears a message like this:

Bluetooth: error in firmware loading err = -110,len = 448, size = 4096 [..] Bluetooth: loading patch file failed

So the problem is that when I try to enable bluetooth, it doesn't work

So I don't know what I have to do

I have put the comands lspci | grep --ignore-case blue and lsusb | grep --ignore-case blue but it doesn't appear nothing

Would you help me?

Thank you!

P.D. I have tried with the command rfkill list and rfkill unlock bluetooth and it doesn't solve the problem

  • Please edit your question and provide the output to lspci | grep --ignore-case blue and lsusb | grep --ignore-case blue – Fabby Dec 20 '14 at 3:38
0

It looks like that model has an Atheros Wifi/BT combo card and the AR3012 has issues in Linux with the xhci drivers and the ath3k module needs to be loaded later. The only workaround I have found involves blacklisting ath3k and using rc.local to load the module echo "blacklist ath3k" | sudo tee /etc/modprobe.d/ath3k.conf and

gksudo gedit /etc/rc.local

and add

modprobe ath3k

above exit 0 Save, exit program and reboot

If you check /lib/firmware/ar3k and there is no such folder you will need to install package linux-firmware also

  • I have enable my NVIDIA Graphics Card and now it detects he bluetooth. Sometimes the bluetooth is soft blocked but I solve these problem with the rfkill command. – Jaime Cepeda Villamayor Dec 21 '14 at 14:57
  • What is the result of lsusb – Jeremy31 Dec 21 '14 at 15:34
  • Bus 001 Device 002: ID 8087:8000 Intel Corp. Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub Bus 002 Device 004: ID 0bda:0139 Realtek Semiconductor Corp. RTS5139 Card Reader Controller Bus 002 Device 003: ID 04f2:b3d8 Chicony Electronics Co., Ltd Bus 002 Device 005: ID 1bcf:0005 Sunplus Innovation Technology Inc. Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub – Jaime Cepeda Villamayor Dec 24 '14 at 10:23
  • Ok I do what you have said and it works – Jaime Cepeda Villamayor Dec 30 '14 at 19:33
  • Can you accept my answer so it will hopefully help others, even if it is more of a workaround – Jeremy31 Dec 30 '14 at 22:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.