2

I upgraded to Ubuntu 14.10 today, and in its version of gedit (3.10.4), the spell-checking plugin highlights misspelled words in light grey. Is there a way to change it back to red? I poked around the Color Scheme Editor and couldn't find a corresponding style.

  • Please try editing /usr/lib/gedit/plugins/terminal.py in the terminal. In that change fg and bg. – vembutech Dec 19 '14 at 6:26
  • After more research, I suspect I need to custom build gedit. I downloaded the source with 'apt-get source' and started poking around. The spellcheck plugin uses PANGO_UNDERLINE_ERROR to mark misspelled words, but doesn't use pango_attr_underline_color_new to change the color of the underline, so the foreground color is used (black, which is light gray when thin). Something must've changed between versions of Pango...I figured I'd add the line myself, but even the stock version won't compile. – paul-s Dec 23 '14 at 5:06
0

This is not really an answer to the problem, but a quick trick:

change the set of colors used by gedit in the preferences. In some sets the light gray is clearly visible.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.