Every time i install or uninstall using the Ubuntu Software Center I get the message:

Package Operation Failed The installation or removal of the software package failed.

I get this for EVERY download right as the download finishes, yet when i click 'ok' it seems that what i downloaded is still there

example:

installArchives() failed: Selecting previously unselected package libdc5:i386. (Reading database ... (Reading database ... 5% (Reading database ... 10% (Reading database ... 15% (Reading database ... 20% (Reading database ... 25% (Reading database ... 30% (Reading database ... 35% (Reading database ... 40% (Reading database ... 45% (Reading database ... 50% (Reading database ... 55% (Reading database ... 60% (Reading database ... 65% (Reading database ... 70% (Reading database ... 75% (Reading database ... 80% (Reading database ... 85% (Reading database ... 90% (Reading database ... 95% (Reading database ... 100% (Reading database ... 191527 files and directories currently installed.) Preparing to unpack .../libdc5_0.3.24~svn3121-2_i386.deb ... Unpacking libdc5:i386 (0.3.24~svn3121-2) ... Selecting previously unselected package libqt4-qt3support:i386. Preparing to unpack .../libqt4-qt3support_4%3a4.8.5+git192-g085f851+dfsg- 2ubuntu4_i386.deb ... Unpacking libqt4-qt3support:i386 (4:4.8.5+git192-g085f851+dfsg-2ubuntu4) ... Selecting previously unselected package valknut. Preparing to unpack .../valknut_0.4.9-2ubuntu1_i386.deb ... Unpacking valknut (0.4.9-2ubuntu1) ... Selecting previously unselected package valknut-translations. Preparing to unpack .../valknut-translations_0.4.9-2ubuntu1_all.deb ... Unpacking valknut-translations (0.4.9-2ubuntu1) ... Processing triggers for gnome-menus (3.10.1-0ubuntu2) ... Processing triggers for desktop-file-utils (0.22-1ubuntu1) ... Processing triggers for bamfdaemon (0.5.1+14.04.20140409-0ubuntu1) ... Rebuilding /usr/share/applications/bamf-2.index... Processing triggers for mime-support (3.54ubuntu1) ... Processing triggers for hicolor-icon-theme (0.13-1) ... Processing triggers for menu (2.1.46ubuntu1) ... Processing triggers for man-db (2.6.7.1-1ubuntu1) ... Setting up mandos-client (1.6.0-1) ... Note: Due to entropy requirements, key generation could take anything from a few minutes to SEVERAL HOURS. Please be patient and/or supply the system with more entropy if needed. Started: Thu Dec 18 19:18:41 PST 2014 gpg: WARNING: some OpenPGP programs can't handle a DSA key with this digest size .+++++++++++++++++++++++++++++++++++..++++++++++.+++++++++++++++++++++++++...++++++++++.>++++++++++.+++++.+++++.+++++.++++++++++.++++++++++..++++++++++>.+++++..>+++++ <...+++++...............................................................................>.............+++++ ++++++++++...+++++.+++++.+++++++++++++++....+++++.....+++++++++++++++..+++++++++++++++++>++++++++++++++++++.+++++..++++++++++.++++++++++...++++++++++++++++++++....+++++.+++++>..>++++++++++>.+++++......>+++++..........+++++^^^^ gpg: fatal: can't open /tmp/mandos-keygen-keyrings.tCwFYmaNzz/trustdb.gpg': No such >file or directory secmem usage: 3424/4896 bytes in 8/14 blocks of pool 5760/32768 dpkg: error processing package mandos-client (--configure): subprocess installed post-installation script returned error exit status 2 Setting up libdc5:i386 (0.3.24~svn3121-2) ... Setting up libqt4-qt3support:i386 (4:4.8.5+git192-g085f851+dfsg-2ubuntu4) ... Setting up valknut (0.4.9-2ubuntu1) ... Setting up valknut-translations (0.4.9-2ubuntu1) ... Processing triggers for libc-bin (2.19-0ubuntu6.4) ... Processing triggers for menu (2.1.46ubuntu1) ... Errors were encountered while processing: mandos-client Error in function: Setting up mandos-client (1.6.0-1) ... Note: Due to entropy requirements, key generation could take anything from a few minutes to SEVERAL HOURS. Please be patient and/or supply the system with more entropy if needed. Started: Thu Dec 18 19:20:20 PST 2014 gpg: WARNING: some OpenPGP programs can't handle a DSA key with this digest size +++++++++++++++.++++++++++..+++++++++++++++..+++++..++++++++++..+++++++++++++++..+++++.+>+++++++++..+++++.+++++..+++++....+++++....+++++.+++++++++++++++.....+++++...+++++>.+++++>......>+++++.............>.+++++ <+++++.............................................................................. <+++++.........>+++++...................................................................>.....>.+++++<+++++...................+++++ ++++++++++.+++++.+++++++++++++++..+++++.+++++.+++++++++++++++..+++++.+++++++++++++++.+++>++++++++++++.++++++++++.+++++.++++++++++.+++++++++++++++++++++++++.+++++>++++++++++.....>......>+++++.........+++++^^^ gpg: fatal: can't open/tmp/mandos-keygen-keyrings.O6N6nUJILO/trustdb.gpg': No such >file or directory secmem usage: 3424/4896 bytes in 8/14 blocks of pool 5728/32768 dpkg: error processing package mandos-client (--configure): subprocess installed post-installation script returned error exit status 2 Errors were encountered while processing:

I ran:

sudo dpkg --configure -a

Setting up mandos-client (1.6.0-1) ... Note: Due to entropy requirements, key generation could take anything from a few minutes to SEVERAL HOURS. Please be patient and/or supply the system with more entropy if needed. Started: Thu Dec 18 19:48:32 PST 2014 gpg: WARNING: some OpenPGP programs can't handle a DSA key with this digest size +++++.+++++.+++++..++++++++++...+++++...+++++.+++++.+++++...++++++++++..+++++.++++++++++>.+++++.......+++++.+++++.+++++...++++++++++..+++++.++++++++++.+++++....+++++++++++++++>.>+++++.>.+++++..................................+++++ .+++++++++++++++++++++++++.++++++++++++++++++++.+++++..+++++..+++++++++++++++.++++++++++>+++++++++++++++.+++++.+++++.+++++..++++++++++++++++++++++++++++++.+++++>++++++++++>+++++>.......>+++++..................................................... <+++++................+++++^^^^^^^^^^^^^^^ gpg: fatal: can't open `/tmp/mandos-keygen-keyrings.e8PUgDtyvI/trustdb.gpg': No such >file or directory secmem usage: 3424/4896 bytes in 8/14 blocks of pool 5760/32768 dpkg: error processing package mandos-client (--configure): subprocess installed post-installation script returned error exit status 2 Errors were encountered while processing: mandos-client

sudo apt-get upgrade

Reading package lists... Done Building dependency tree
Reading state information... Done Calculating upgrade... Done 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. 1 not fully installed or removed. After this operation, 0 B of additional disk space will be used. Do you want to continue? [Y/n] y Setting up mandos-client (1.6.0-1) ... Note: Due to entropy requirements, key generation could take anything from a few minutes to SEVERAL HOURS. Please be patient and/or supply the system with more entropy if needed. Started: Thu Dec 18 19:14:12 PST 2014 gpg: WARNING: some OpenPGP programs can't handle a DSA key with this digest size ++++++++++..+++++.+++++.+++++++++++++++..++++++++++.........+++++..+++++++++++++++....++>++++++++++++++++++...+++++++++++++++....+++++....+++++..+++++..+++++.+++++++++++++++>.++>+++..+++++ ++++++++++..++++++++++.+++++.+++++++++++++++++++++++++.+++++++++++++++.++++++++++..+++++>++++++++++.++++++++++++++++++++.++++++++++..+++++++++++++++++++++++++>++++++++++........>...>+++++.<+++++...>+++++...................+++++^^^^ gpg: fatal: can't open `/tmp/mandos-keygen-keyrings.hfuSU3sSIu/trustdb.gpg': No such >file or directory secmem usage: 3424/4896 bytes in 8/14 blocks of pool 5728/32768 dpkg: error processing package mandos-client (--configure): subprocess installed post-installation script returned error exit status 2 Errors were encountered while processing: mandos-client E: Sub-process /usr/bin/dpkg returned an error code (1)

now, it doesn't seem like anything is going wrong, i tried a few other commands such as:

sudo apt-get -f install sudo apt-get clean sudo apt-get auto clean

i also followed the instructions here but with no luck.

This didn't start happening until purging using the instructions for not enough free space when upgrading

How do i resolve this message?

up vote 0 down vote accepted

Did you give a try with purging mandos-client?

$ sudo apt-get autoremove --purge  mandos-client 

This should remove this package in a clean way, so that you can install later.

  • That solved it. Now sudo apt-get upgrade is putting out: The following packages have been kept back: linux-generic linux-headers-generic linux-image-generic 0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded. – Shut Up Dec 19 '14 at 4:52
  • The previous comment was solved just fine with sudo apt-get dist-upgrade – Shut Up Dec 19 '14 at 5:11

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.