I was playing around with some settings, and now I need to reset GNOME to it's defaults - how do I do that?

9 Answers 9


For Unity-related configuration resetting, take a look here.

For Ubuntu 17.10 and higher, you can reset all the settings using dconf.

This command will delete your configuration files. Once it's run there is no going back!

Still with me?


Run the following on a terminal or with Alt+F2:

rm -rf .gnome .gnome2 .gconf .gconfd .metacity

That will remove all the GNOME 2 configuration settings. Log out, and log back in. You'll be back to a stock desktop.

You can backup before playing around with your settings in the future:

mkdir ./.old-gnome-config && mv ./.gnome* ./.old-gnome-config && mv .gconf* ./.old-gnome-config && mv ./.metacity ./.old-gnome-config


If your config isn't worth saving run the following:

rm -rf .gnome .gnome2 .gconf .gconfd .metacity .cache .dbus .dmrc .mission-control .thumbnails ~/.config/dconf/user ~.compiz*

To back up and reset GNOME3:

mkdir ./.old-gnome-config/ && mv ./.gnome* ./.old-gnome-config/ && mv .gconf* ./.old-gnome-config/ && mv ./.metacity ./.old-gnome-config/ && mv ./.cache ./.old-gnome-config/ && mv ./.dbus ./.old-gnome-config/ && mv ./.dmrc ./.old-gnome-config/ && mv ./.mission-control ./.old-gnome-config/ && mv ./.thumbnails ./.old-gnome-config/   && mv ~/.config/dconf/* ./.old-gnome-config/
  • 10
    more concise and precise to use a for loop for the backup step, e.g. for f in .gnome .gnome2 .gconf .gconfd .metacity; do mv $f ${f}.bak; done or mkdir -p ~/.backup-gnome-config/ && for f in .gnome .gnome2 .gconf .gconfd .metacity; do mv $f ~/.backup-gnome-config/; done
    – hobs
    Commented Aug 13, 2012 at 1:38
  • Shorten that last bit to mkdir ./.old-gnome-config/ && mv ./.gnome* .gconf* ./.metacity ./.cache ./.dbus ./.dmrc ./.mission-control ./.thumbnails ~/.config/dconf/* ./.old-gnome-config/
    – smac89
    Commented Dec 22, 2016 at 19:08

For 17.10+

There isn't a great solution but this may do the job or most of it.

dconf reset -f /org/gnome/

Then log out/in

That command's path could be shortened if needing a more extensive reset, i.e. to just /org/ or even / but I'd go with above first.

Worst case one could also just go this in a terminal, I think it's a bit overkill as it will set all dconf (gsettings) back to defaults

mv .config/dconf/user .config/dconf/user.bak && sudo reboot

Fore me those directories were not sufficient - I had to delete ~/.config/dconf/user as well.

This helped for me in those two cases:

  • gnome-panel config broken (tried to specify location "left" for one gnome panel, it immediately crashed and could not be started afterwards)
  • GTK Theme and GTK Icons broken (nevertheless the selection via e. g. gnome-tweak-tool, it remained in ugly Windows-style grey look and icons were standard gnome - I have no clue how this was provoked, it appeared suddenly after login)

This corresponds to the Gnome 3 Fallback Mode I use on Linux Mint 12 Lisa (Oneiric based). But the GTK problem persisted in all other login modes as well (MATE, Gnome 3 Standard)!

I am unsure now to which mechanism the ~/.config/dconf/user file corresponds, as I found out that in Linux Mint only _mateconf-editor_ is installed by default but outfitted with the title and icon of gconf-editor from Natty! After installing gconf-editor additionally, this one is titled identically but has a different (new) icon. But don't rely on this icon stories, because this will rely on the icon theme which is Mint-X-Dark for me.

Theory says that dconf is the successor for gconf, but I found no information regarding the GUIs.

  • 1
    Yes, I had the same problem and needed to remove ~/.config/dconf aswell
    – wim
    Commented Jan 4, 2012 at 23:25
  • +1 for the info, but it'd be even better if you rewrite to incorporate your edits
    – djeikyb
    Commented Jan 5, 2012 at 22:23
  • This helped with the missing Lock Screen menu option (which is probably down to yet another corrupt dconf config)
    – prusswan
    Commented Nov 30, 2012 at 4:59
  • 1
    Saved my life! Spent the last two hours unable to load my Ubuntu desktop, but deleting ~/.config/dconf/user did the trick
    – leopld
    Commented Jan 9, 2015 at 14:52
  • This is weird, i have to delete this file after every reboot to avoid login loop. Commented May 4, 2018 at 16:33

If you want to reset your GNOME specific settings to default as if you had never logged in try

rm -rf .gnome .gnome2 .gconf .gconfd .metacity

Resetting Gnome Extensions

If you need to remove your Gnome Extensions (I ran into this problem when trying out Ubuntu 17.10 on an upgraded system) run:

rm -rf ~/.local/share/gnome-shell/extensions

Keep in mind that this will wipe all of your extensions.

To remove an individual extension, you can navigate to ~/.local/share/gnome-shell/extensions and look for the extension's folder, then delete it.

If you'd like to backup

To backup, run:

cp ~/.local/share/gnome-shell/extensions ~/.local/share/gnome-shell/extensions-bkup
  • now my extensions don't load. any fix for that? I've installed the again from the site but either all don't work or just some works
    – Tosho
    Commented Dec 25, 2017 at 2:44
  • @Tosho a couple of things: 1. Did you check to see that the extensions you installed are compatible with your Gnome Shell version? 2. Have you restarted Gnome Shell or logged out + logged back in?
    – RolandiXor
    Commented Dec 25, 2017 at 17:05
  • I've re-installed Ubuntu Gnome 17.04 keeping my using my old /home partition. Now after some cleaning, re-installs and deleting, now most of them seems to work just fine. Only few extensions got ERROR after Updating from extensions.gnome.org or they crash randomly and restart doesn't fix anything. I'll leave it like it is for now. Thanks
    – Tosho
    Commented Dec 26, 2017 at 18:09

Logout, switch to command line (Alt + Ctrl + F4), login, do:

rm -rf .gnome .gnome2 .gconf .gconfd .metacity

Switch to X (Alt + Ctrl + F2, F7 on older versions).

Just like they described it here.


You can use the mv command.

The syntax is:

mv source1 source2 source3 ... sourceN destination

In your case:

cd ~
mkdir .old-gnome-config
mv .gnome .gnome2 .gconf .gconfd .metacity .cache \
.dbus .dmrc .mission-control .thumbnails .config/dconf/user \
.compiz* .old-gnome-config/

The last one is a directory and it's the destination.

  • Explanation: This is moving the old configuration to backup destination ./.old-gnome-config/ it needs to be run in the home directory. Afterwards ubuntu restores the default configuration.
    – mondjunge
    Commented Oct 21, 2013 at 10:22
  • @mondjunge you have edted my comment. I'll do it accordingly.
    – maxadamo
    Commented May 11, 2019 at 16:45

Reinstalling gnome-tweak-tool resolved this issue and after reboot the GNOME 3 come up again. Actually gnome-tweak-tool was installed but the system detects it as a uninstalled one.

  • 6
    Are you saying that reinstalling gnome-tweak-tool actually resets GNOME settings to their defaults? Or just that it can fix some problems that might motivate someone to want to reset them? Commented Oct 7, 2012 at 12:15
  • Issue is Gnome settings reset. Reinstalling 'gnome-tweak-tool' does not reset Gnome settings. Commented Apr 5, 2018 at 14:49

I did :

cd $HOME
cd .config
rm -R *
sudo reboot

And I've found my desktop like the first day I create my user account, but all my software params are the same (firefox, thunderbird, filezilla...)

  • Its help me.. Thanks @P-J Marquet Commented Mar 30, 2016 at 10:59
  • 4
    This resets EVERYTHING that uses ~/.config to store configuration data. NOT recommended.
    – RolandiXor
    Commented Dec 20, 2017 at 0:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .