0

What I did before this error:
I was trying to install mysql for registration in OpenMRS database and it was succesfully, but i forgot my password. And removed mysql packages, i was getting some errors while this process. Then I tried to install packages and got errors, e.g. "missing dependies", "broken package". I tried to search Google, but nothing helped. So, I can't to remove 'em.

I can't purge mysql packages, because when I run:

sudo apt-get remove --purge mysql-server mysql-client mysql-common

I get weird confirmation-output(screen below), it wants to remove plasma-packages, korganizer, etc. So, I can't reinstall MySQL (i forgot password). I'm afraid to confirm this operation, why do it need this packages to delete?

My Screen: http://i.stack.imgur.com/FP7Hj.png

  • You have physical access to the server? If yes recover the password is quite simple. For the image, it seems that you have not added the -- of command --purge – Renato Tavares Dec 18 '14 at 15:14
  • Renato Tavares, i tried to use both variants(with/without "--") - the same result. Sorry for dumb question I'm a newbie in this stuff: which server? I've updated description for more info! – pushandpop Dec 18 '14 at 15:19
  • Don't remove mysql-client. Only mysql-server. – davidbaumann Dec 18 '14 at 15:26
  • @davidbaumann, with "--": the same stuff, wants to delete kde, plasma and others packages. without "--": error: Reading package lists... Done Building dependency tree Reading state information... Done E: Unable to locate package purge – pushandpop Dec 18 '14 at 15:29
  • ?? Just run sudo apt-get remove --purge mysql-server – davidbaumann Dec 18 '14 at 15:30
1

I've decided to remove all packages that apt was suggesting me, including (muon-updater, qt-propeties and others as you can see on screenshot). I was afraid to do that, because it's very important packages, but all works just fine ;) But not every purge/remove command would suggest you to delete a huge amount of packages.

I used this one:

sudo apt-get remove --purge mysql-server mysql-client mysql-common

After uninstallation packages, I was able to install mysql-server without any errors.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.