1

I have upgraded my Ubuntu (from anno dazumal) to 14.10 and lost the standard behaviour of ALT-key of my old account. The left ALT are now a ISO_Level3_Shift.

A new made account have a correct ALT-key.

1) I have tried to find what (old) config file that results in this change of keyboard configuration. I removed almost all .-files and files in .config I could find. (no luck)

2) I have reconfigured the keyboard using xmodmap and a local ~/.xmodmap-file.

keycode  92 = Alt_L Meta_L Alt_L Meta_L

Gives me an ALT that can activate HUD but combinations with other keys does not work such ALT+TAB, CTRL+ALT+LEFT etc

I would prefer to find and remove the configuration that destroys my ALT-key (1) rather than add a new configuration that alter the wrongful configuration (2).

Any ideas?

2

There is probably no one that know exactly where the keyboard configuration is kept. It depends if you have ibus set (by default yes), which xkb settings you have, and from the registry-under-another-name which has become the gsettings database.

Try to use dconf-editor and compare bits of configuration under the schema desktop.ibus and/or org.gnome.input-sources --- a screenshot of the latter follows.

dconf-editor for keyboard


PD yes, I'm quite sad about the situation. International keyboard is mostly broken on Ubuntu since 13.04, plenty of bug reports around, and still not solved.

  • Thank you, i found the key that misconfigured the keyboard! I just had to set it to [] – Anders Wallenquist Dec 18 '14 at 20:26
  • Which one das it? It would be nice to add it to the answer to help future readers.... – Rmano Dec 18 '14 at 22:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.