21

Ever since I upgraded to 14.10 I get a strange behavior on my desktop. I get popups claiming "Authentication is required to change your own user data" and a prompt for my password. It happens at random times, though it seems to get triggered by my actions. For example, it happens every time I switch keyboard layouts, but only after I've been working for a while. Sometimes it pops up several times in a row.

Hitting "Cancel" doesn't seem to cause any problems.

Clicking "Details" on the authentication dialog reveals Action: org.freedesktop.accounts.change-own-user-data and Vendor:.

I looked at /usr/share/polkit-1/actions/org.freedesktop.accounts.policy, and under the change-own-user-data action, the settings are:

<defaults>
  <allow_any>auth_self</allow_any>
  <allow_inactive>auth_self</allow_inactive>
  <allow_active>yes</allow_active>
</defaults>

I don't have any interesting files under /etc/polkit-1.

My laptop has a very similar setup (14.10, same policy files) but the problem does not exist there.

Is there a way to find what is triggering those popups, or better yet, just get rid of them?

  • Try with creating a new user and change all the files to the new user. After doing this continue working. – vembutech Dec 17 '14 at 6:17
  • I have the same problem. Which files are talking about replacing here? – TCZ8 Jun 18 '15 at 12:38
  • Same problem on 15.04 - happens every time I switch back to my user after my wife or kids have been using their users for a while, if my user stays logged in to the computer. – jaywink Jul 2 '15 at 19:13
  • 1
    Looks very much like bugs.launchpad.net/ubuntu/+source/policykit-1-gnome/+bug/…, but I don't want to close the question as long as the connection is not confirmed. – guntbert Jan 25 '16 at 15:59
  • 1
    @guntbert "It's this bug" should be an answer, not a close reason. – Oli Mar 30 '16 at 6:58
2

Have you tried to rewrite the permissions to your home directory? open terminal:

cd /home/
chown -R your-account-name your-account-name
2

This looks very much like a confirmed bug: Annoying dialog "Authentication is required to change your own user data"

As of now there exist workarounds (partly mentioned in other answers to this question) but neither the exact cause nor a real solution is known.

Instead of changing a system policy in a way where I don't know potential side effects I opted to live with the dialogue for now. Of course I don't want to authorize an unknown action, so the quickest way to deal with it is

  • select the dialogue (so that is has the focus)
  • press ESC until the last of the dialogues is closed.
1

This worked for me:

1) At Settings -> Session and Startup ( Application Autostart TAB )

Session and Startup

Uncheck PolicyKit Authentication Agent

( /usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1 )

2) In a Terminal:

sudo killall polkit-gnome-authentication-agent-1

My Desktop was running:

  • Distributor ID: Ubuntu
  • Description: Ubuntu Wily Werewolf (development branch)
  • Release: 15.10
  • Codename: wily
  • 2
    Does this really fix the problem? Just seems like a workaround - or is the policy kit agent not used anymore? – codeling Nov 4 '15 at 22:41
  • I, too, have seen this recommendation posted in several places around the net in response to this issue, but I've yet to see an explanation as to why this is a safe thing to do. – BlueBomber Dec 21 '15 at 17:50
  • It worked for me but I don't know the collateral effect. – Felipe Feb 13 '16 at 21:04
0

Changing the org.freedesktop.accounts.change-own-user-data policy from auth_self to yes will fix this:

$ printf '[Do not prompt users with "Authentication is required to change your own user data" messages]\nIdentity=unix-user:*\nAction=org.freedesktop.accounts.change-own-user-data\nResultAny=yes\nResultInactive=yes\n' | sudo tee /etc/polkit-1/localauthority/50-local.d/org.freedesktop.accounts.change-own-user-data.pkla
[Do not prompt users with "Authentication is required to change your own user data" messages]
Identity=unix-user:*
Action=org.freedesktop.accounts.change-own-user-data
ResultAny=yes
ResultInactive=yes
  • 1
    Please explain why your recommendation is a safe thing to do. – BlueBomber Dec 21 '15 at 17:50
  • @BlueBomber At least this is better than disabling the whole service as Leonardo recommends. – ziggystar Jan 12 '16 at 8:12
  • 6
    @ziggystar , how would I know that? I don't know anything about the nature of this bug or the service that people are recommending to disable (or bypass), and no one that I've seen is providing any reassuring info about these solutions... – BlueBomber Jan 18 '16 at 13:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.