0

Ok, I will describe each & every step I performed.

First the problem:

A few days ago, my laptop refused to boot. It showed me automatic repair, but the repair was unable to solve the problem. So I checked the log file. The log file said that the bootloader was not found.

Since I was in a hurry for my work. I booted an Ubuntu live CD & tried to write the bootloader

I ran a command in ubuntu Sudo dd if=/usr/syslinux/mbr.bin of=/dev/sda

What it did is make situations worse.

This command deleted my system_drv partition which was the boot partition.

So I ran testdisk & recovered that partition.

In testdisk I selected Intel type partitions for recovery.

Though the partition was recovered it wiped data from the rest of my partitions. Now in my laptop there is a LENOVO partition containing the lenovo drivers, SYSTEM_DRV (boot) & some other recovery partitions. Two partitions remain one was Data & other is Windows8_OS.

When I did my first recovery should I have selected efi/gpt instead of Intel? & if yes is it possible to recover now or I have lost my data?

My final questions are:

Should I try to recover those partitions using testdisk? Or Is There Any Other Reliable Software? Or Is There Any Alternate Way? Or should I just handover to Lenovo for repairing the drive.

Though the data is gone I have checked in Gpart & confirmed that the partitions are still intact & I assume the partition table is also intact. The partitions still showup in Gpart but with an red exclamation & no used space just the size of the partition.

Please suggest a solution I am very worried coz my data is too important & want to restore my laptop as it was. Please I am in need of help.

  • You/we need to really know if system was UEFI with gpt partitioning or BIOS boot with MBR(msdos) partitioning. The syslinux install is a Windows only boot loader for BIOS boot of Windows. It should not have caused any issued with UEFI boot, but BIOS or UEFI is controled by settings in UEFI/BIOS. You may be able to convert back to gpt if it was gpt, but may make it a lot worse if it really was MBR. What does gdisk show: rodsbooks.com/gdisk/mbr2gpt.html Do not press w or write the new partition table unless you are sure it is gpt. – oldfred Dec 17 '14 at 5:29
  • @oldfred Hey, here is gdisk & a gparted screenshot dropbox.com/sh/904rnyc5bwfpfwi/AACiCaRk4wSIIUEOHpFdpgAga?dl=0. Please can you tell me how to proceed. – user359460 Dec 17 '14 at 13:54
  • It is gpt and Windows partition look like a typical UEFI boot. Windows only boots from gpt partitioned drives with gpt partitioning, so cannot be MBR. Did gdisk show any error or issue with partition table. The only issue shown seem to be every NTFS partition with gparted. What does right click on red error icon show in gparted? You may need to run chkdsk from a Windows repair disk or whatever else the error may be. You cannot run chkdsk from Linux, only Windows or perhaps some third party Windows tools. It looks like sda2 needs boot flag to make it the efi partition. Then you may boot UEFI. – oldfred Dec 17 '14 at 15:33
  • It may have been installing syslinux moved boot flag from sda2 and that was entire issue. Errors on NTFS may be because you left it hibernated. – oldfred Dec 17 '14 at 15:35
  • @oldfred The error on right click say ERROR(5): Failed to check '/dev/sda1' mount state: Input/output error. Probably /etc/mtab is missing. It's too risky to continue. You might retry an another Linux distro. There was no error from gdisk on execution of sudo gdisk -l /dev/sda. It says found valid gpt with protective MBR; using GPT & then lists all partitions. So should I recover partitons first? & then set SYSTEM_DRV boot flag & then I would be able to boot in windows? – user359460 Dec 17 '14 at 15:54
0

Atlast I went to Lenovo Service Center for re-installing my OS. Which they did. I am not happy at all with the Lenovo Service Center at Impact Infotech Pvt. Ltd., Goregaon (East). While they did install my Operating System they deleted all partitions including the Lenovo partition which had the Drivers of my laptop, they don't have any knowledge regarding any issues related to an Operating System. Plus they charged me Rs. 800 for installing a pirated Operating System.

I recommend DO NOT GO TO THIS Lenovo Service center they will install a pirated OS on your laptop instead of installing from a recovery disc & laptops nowadays show "Media Test Failed" when they are switched from UEFI to Legacy Support. They will trick you that your Hard Disk is damaged & will charge you extra bucks for it.

Now I am having a working laptop with Windows 8.1 Pro which he installed.

Thanks to @oldfred for helping me solve my problem. I learned a great deal of knowledge from you. Keep up the good work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.