6

I'm using Ubuntu 14.04 LTS.

Yesterday when I logged in, I found out that the Wi-Fi indicator disappeared. However the main problem is that Dropbox indicator is located on the left, above the Dash icon.

Partial screen shot

I searched for solutions on the web, but didn't find anything. Does anyone have some suggestions?

  • I am not sure what you mean. My wifi iconis on the top right of the screen, and the Dropbox icon will probably disappear after a restart (or log out/log in)? – Jacob Vlijm Dec 16 '14 at 23:01
  • no, i restarted several times and the dropbox icon still here – Davide Rossetto Dec 16 '14 at 23:09
  • David, coincidentally, my wife's computer just had the same. right-click on the icon (first you might have to close all other apps to get to the icon), choose "close Dropbox" then restart Dropbox from Dash. – Jacob Vlijm Dec 16 '14 at 23:16
  • 1
    @JacobVlijm If that fixed your problem perhaps you should post it as an answer? :) – Seth Dec 17 '14 at 3:09
  • Same problem here. right-click on the icon and choose "Close Drobox" didn't work in my case. I had to execute dropbox stop and dropbox start in the terminal. However, this procedure fixes the problem just for that time. I didn't find any other solution fixing the problem permanently. – f_ficarola Dec 17 '14 at 6:32
6

Coincidentally, I just ran into the same issue. It seems to be a bug, because restarting Dropbox fixes it temporarily, but only until the next restart. To fix it permanently, we need to edit and rename the dropbox.desktop file in ~/.config/autostart/

How to fix it permanently:

  • rename the file ~/.config/autostart/dropbox.desktop into: start_dropbox.desktop

    [You need to rename it because Dropbox overwrites the file dropbox.desktop on every startup]

  • Open the (renamed) file with gedit (drag it over an open gedit window).
  • Replace the line, starting with Exec=, change it into:

    Exec=/bin/bash -c "sleep 10&&dropbox start -i"
    

    This delays the startup of Dropbox with 10 seconds after log-in, which does the trick.

  • in Dropbox preferences, untick "Start Dropbox on startup" (else we would have two .desktop files representing Dropbox in the autostart folder):

    enter image description here

  • In Startup Applications (Dash > Startup Applications) remove the Dropbox entry (but not the newly created start_dropbox.desktop).

    enter image description here

  • In the folder ~/.config/autostart, remove the original dropbox.desktop if it is still there.

Now on restart, it should be in the right place.

Explanation

The bug seems to be related to the timing of the Dropbox startup. The workaround above replaces the "real" Dropbox starter with one that delays the startup 10 seconds, until the desktop is ready.

  • I'm having same issue with HALL application, I've tried to prevent it with the way above but nothing changed, so could you share any idea about how to fix it especially HALL? – Mustafa Güven Mar 12 '15 at 12:50
1

I followed the directions in the accepted answer but it didn't help in my case (I'm also using Unity on Ubuntu 14.04 LTS). Interestingly, I also had somehow lost the Wifi indicator, and following a fix for that issue, found here:

No wi-fi icon/ option in Ubuntu 14.04

..also fixed the placement of the Dropbox icon.

  • The new Dropbox version 3.x has been causing a lot of issues in different Linux distros. My personal temporary solution was to just use 2.10.51 until some of the issues get worked out. Instructions here: forums.linuxmint.com/… – jbrock Jan 17 '15 at 20:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.