I followed instructions from this topic https://askubuntu.com/a/33703/13207 to move SWAP and enable it for hibernating. All works fine, the system recognizes the new SWAP, swap is the same size as RAM.

$ swapon -s
Filename                Type        Size    Used    Priority
/dev/sda2             partition    16382972   0        -1

Then I moved to this topic http://ubuntuhandbook.org/index.php/2014/04/enable-hibernate-ubuntu-14-04/ and found a command to test if hibernate works

 sudo pm-hibernate

After this I can see that the system is saving data to the disk (disk indicator flashes) and the system goes off. I previously checked and saw that there is 2GB of data to be save to hibernation.

But, when I try to turn it on, I get hang on the black screen with a cursor.

Anyone has idea why I cannot boot back from hibernate?

  • 1
    can you resolve problem? i have this problem – DolDurma Apr 1 '15 at 15:07
  • 2
    @Mahdi.Pishguy Nope. I gave it up. Don't use hibernate – ubuntico Apr 1 '15 at 15:20

If you want to use your swap for hibernating then you need to update the UUID in

/etc/initramfs-tools/conf.d/resume

with this content

RESUME=UUID=xxx.

Don't forget to

sudo update-initramfs -u



One can also overcome black screen issue by editing the grub configuration. Do this if you have created a swap at the time of installation:

sudo gedit /etc/default/grub

Find the line reading: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

Add nomodeset to the end, inside the quotes:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"

Exit from gedit and save the file. Make grub aware of the new changes:

update-grub2

I had this problem and solved it with Debian installer usb stick. You can use any installer that has a partitioning tool for you to use manually.

It started as the system accidentally hibernated as battery ran out while I was playing Civilization so the image was huge and propably bad. The recovery console didnt come up. I didnt find any options from grub to stop the reading of the hibernate image. (this was in debian on macbook pro 13 retina 2015 so no way to press sysrq etc...)

So I started the system with the Debian Installer "expert mode" and let it go on until the "detect disks" and "partition" section of the installer. Then I just cleared the SWAP partition from there. Wrote the changes but didn't let the installer continue of course.

In case you use a swap file you would need to mount the partition from recovery console of the installer and find the swap file and remove it. I haven't done this my self so do seek help from elsewhere also.

The next boot was fine and didn't try to recover as there was no image to recover from.

Hope this helps you guys though you propably have found a solution already else where.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.