I have read all the other info about this subject but can't get this to work.

I have a Tegra Jetson TK1 board with Ubuntu 14.04 on it, I tried to update and upgrade Ubuntu, but now I can no longer see anything on my screen after the initial start (the list of tasks in text mode and NVidia logo shows up and then the screen goes black).

I tried to hold the shift key while booting, push Ctrl-Alt-F1 among other things, but I can not stop the GUI to load.

Anyone knows hoe I can get a terminal so I can recover the OS?

Really appreciate you help.

  • I would try to use a liveusb-stick (or cd) to edit the /etc/rc2.d directory to prevent the gui to be loaded. usually it should be runlevel 2, you can try other runlevels, too – LittleByBlue Jan 13 '15 at 19:25

I've worked with the Jetson TK1 and upgrading/updating Ubuntu is a known issue. The libglx.so file gets overwritten. You need to run: "sudo apt-mark hold xserver-xorg-core" before updating. See wiki page here for more info: http://elinux.org/Jetson_TK1#An_important_step_before_connecting_the_Jetson_to_Internet

Apparently this has been solved with the latest TK1 image provided by Nvidia.

I've had the best luck flashing the device using the JetPack. (https://developer.nvidia.com/jetson-tk1-development-pack). It requires Ubuntu 12/14 64-bit. And for some reason it takes up a many gigs of disk space and I can't seem to get rid of it even after uninstalling. You might want to take a snapshot before installing if you're using a VM.

Hope that helps.


| improve this answer | |
  • this might be the better answer. – LittleByBlue Jan 13 '15 at 19:27
  • I have to try this, had to stop working on it for a while, but this sounds a much better solution. – FarhadA Jan 15 '15 at 9:08

This link tells you how to boot Ubuntu in recovery mode (provided you're using the Grub bootloader):


If that doesn't work then you can always create a live CD/USB from another machine and boot up with that to recover your system. If you don't know how to do that I can post links to some useful resources.

UPDATE: The Linux/Ubuntu on Tegra K1 Jetson board is alightly different than the one used by desktop and laptops.

| improve this answer | |
  • Thanks, but the shift does not seems to work to bring the grub menu,I am looking for a Serial cable, that might help me to connect to the unit using a terminal. – FarhadA Dec 16 '14 at 16:26
  • 1
    Oh, I see ... it's a development board that came with Ubuntu pre-installed. Maybe it's not quite as simple as plugging in a live USB then :-) – Time4Tea Dec 16 '14 at 16:36
  • Yes, I finally got it to stop after repeatedly hitting space, escape and all other keys, and re-installed Ubuntu and the problem is solved. – FarhadA Dec 17 '14 at 17:24
  • Cool - glad you got it to work. Still a bit of a mystery as to what was causing it though. – Time4Tea Dec 17 '14 at 18:57
  • Too quick to cheer, after a day of working properly, it stopped working again.This is well known problem with the version of Ubuntu that comes with the Tegra K1 Jetson board. It is really annoying, now I can not even get to the prompt any more, got to bring back the serial cable again. – FarhadA Dec 18 '14 at 16:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.