0

I'm having issues seeing specific WiFi networks. I'm running Ubuntu 14.04.1 on a late 2010 MacBook Air. At first I thought it was the internal wireless adapter so I bought a USB one but that didn't solve the problem. I also can't see the same networks if I use the MacOS X (Mavericks) partition so I'm a bit lost as to why this could be.

I ran the wireless-info script with the USB wireless adapter attached

I'll post it in a comment because I get an error for too long a post.

Edit

This is the link to the log.

http://pastebin.com/jzjviHp4

  • Is it the internal or the USB you want to fix? I suspect they conflict and you ought to work on one at a time. – chili555 Dec 16 '14 at 16:01
  • If I had to choose one, the USB adapter would be it. I first had the problem without the adapter and that's why I bought it. – Juan Pablo de la Vega Dec 16 '14 at 16:04
0

I suggest you blacklist and unload the driver for the internal device:

sudo -i
echo "blacklist wl"  >>  /etc/modprobe.d/blacklist.conf
modprobe -r wl
exit

Then fix the USB as described here: NETIS WF2120 Wifi Adapter Drops Signal Within Seconds

| improve this answer | |
  • Thanks for the answer! I still haven't been able to try it out. Will let you know how it goes when I do. – Juan Pablo de la Vega Dec 18 '14 at 21:34
  • It worked great! After building the new driver wiz the instructions in the link, I removed the internal device driver from the blacklist and now both adapters can see the WiFi network. – Juan Pablo de la Vega Dec 30 '14 at 10:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.