57

I am using Ubuntu 14.04 LTS. When I open a site which requires flash plugin (e.g. Youtube), Firefox says This plugin is vulnerable and should be updated.

Screenshot

However if I click Check for updates... there is no update at all. This is what the update site listed:

  1. Shockwave Flash 11.2 r202 (status up to date 11.2.202.424)
  2. Java(TM) Plug-in 11.25.2 (status up to date 11.25.2)

So what should I do?

  • Maybe something changed in Firefox settings (about:config). Consider trying flash in another browser to find out who is guilty. – Muzaffar Dec 16 '14 at 13:29
  • 1
    Type about:plugins in your Firefox address bar, and search for flash player. What version does it list? Does it list 11.2.202.424 or 11.2.202.424? Go to Adobe's flash version tester (clicking "Activate Adobe Flash"), and look at what version it says you have. Does it say "You have version 11,2,202,424 installed" or "11,2,202,425"? 11.2.202.425 is the proper latest version. For some reason Firefox seems to mis-detect what version is installed. Finally, exactly what version of the flash package do you have installed on your machine? – D.W. Dec 18 '14 at 5:46
  • @D.W. If I install adobe-flashplugin: about:plugins says 11.2.202.359; adobe's site says 11,2,202,359 If I install fashplugin-installer: about:plugins says 11.2.202.425; adobe's site says 11,2,202,425 – fikr4n Dec 19 '14 at 2:54
  • 1
    @BornToCode, Excellent -- that's a great clue. 11.2.202.425 is the latest version -- that's the one you want. Sounds like the answer is to use flashplugin-installer (not adobe-flashplugin). That, combined with the details from DJCrashDummy, sounds like the answer. Want to post an answer that explains all of this? This should be very useful to others. – D.W. Dec 19 '14 at 3:16
  • I've installed 11.2.202.481 and this still seems to be vulnerable? Should I always allow? No problems with Chrome. – JohnnyBizzle Jul 16 '15 at 6:53

11 Answers 11

52

I've done some research at mozilla and adobe and tests with both recent LTS-versions (14.04 and 12.04) and I'm pretty sure it is just a numbering problem of the flash-plugin!

To make a long story short:
If you open in firefox "tools" - "add-ons" - "plugins" respectively look at the mozilla check and you've got version 11,2,202,425 (notice the commas!), you will get this error message.
and if your version is 11.2.202.425 (same version, just with dots at the numbering) everything is fine.

So don't panic, your system is safe! ;-)


But I can understand that this message is annoying and so this would be the easiest way to get rid of it:
open a terminal and insert sudo apt-get update && sudo apt-get install -y flashplugin-installer, type your root-password (no characters will be displayed) and just wait till executed!


I would recommend this solution just in the case you have already installed the latest version but still get the error message because of the differences between the flash-packages!

  • For adobe-flashplugin, both of the checks show 11.2.202.359, but for flashplugin-installer it is 11.2.202.425. – fikr4n Dec 19 '14 at 3:07
  • 4
    after trying to update it says "already the newest version" but the anoying message still appears – user47206 Jul 7 '15 at 10:03
  • 1
    I typed in the terminal the above string, 'sudo apt-get update && sudo apt-get install -y flashplugin-installer'. It worked perfectly on my 14.04 LTS. I got 'flashplugin-installer_11.2.202.491ubuntu0.14.04.1_amd64.deb' installed. – bluepearlsky Jul 17 '15 at 16:57
  • 2
    I didn't have any commas in the version number, but used this solution all the same and it worked perfectly! – Ingrid Jul 22 '15 at 10:39
  • 1
    This worked for me – Linga Aug 18 '16 at 8:50
8

Following solution worked for me:

sudo apt-get purge flashplugin-installer
sudo apt-get install adobe-flashplugin
7

The best solution to the problem of a vulnerable, out-of-date Flash installation--or even an up-to-date one that works poorly--may be to uninstall Flash entirely. Often it is not needed, as HTML5 has largely taken over. Thus removing Flash is a real solution for many people, and should probably be considered first before moving on to other solutions that attempt to keep Flash installed while maintaining it in a current (or semi-current) state.

As occupyflash.org says:

Flash Player is dead. Its time has passed. It's buggy. It crashes a lot. It requires constant security updates. It doesn't work on most mobile devices. It's a fossil, left over from the era of closed standards and unilateral corporate control of web technology. Websites that rely on Flash present a completely inconsistent (and often unusable) experience for fast-growing percentage of the users who don't use a desktop browser. It introduces some scary security and privacy issues by way of Flash cookies.

Flash makes the web less accessible. At this point, it's holding back the web.

  • 2
    Can you give an actual path to uninstalling the software? Preferably a shell command. – Tarrasch Apr 20 '15 at 20:54
  • 1
    Shell command to uninstall flash: "sudo apt-get remove adobe-flashplugin" it worked for me and I can watch videos now – wranvaud Jul 15 '15 at 3:00
  • 1
    Sadly, one still needs it to watch Amazon streaming videos. Usually I use Chrome, but need Firefox for this too. I would rather be using HTML5! – Rafael_Espericueta Jul 29 '15 at 16:57
  • 1
    I didn't even think of doing this. Great suggestion. – DazBaldwin Nov 9 '15 at 11:05
4

As announced by Adobe Adobe Flash Player 11.2 will be the last version to target Linux as a supported platform.

  • There is however an 11.2.202.425 update available at the time of this writing – Fabby Dec 17 '14 at 1:36
  • @Fabby update doesn't equal to a newer version, Firefox will keep complaining, unless you switch to pepper flash or html5, which is what i did – Sergiy Kolodyazhnyy Feb 13 '15 at 22:17
  • @Serg: спасибо: I've never had any problems, about any web sites complaining, but then, I'm not the average user... ;-) – Fabby Feb 14 '15 at 8:45
3

The main problem in this situation is outdated version of Flash Player in Firefox, which is 11.2
In the same time, Google Chrome users enjoying latest version supported by Google.

The trick is to switch Firefox from using it's Flash Player to Pepper Flash Player from Google Chrome.

  1. First of all lets remove that we have:

    sudo apt-get remove flashplugin-installer
    sudo apt-get remove adobe-flashplugin

  2. Install Fresh Player Plugin by Rinat Ibragimov.
    It is wrapper which allows Linux users to use Pepper Flash (which is bundled with Google Chrome) in Firefox and other NPAPI-compatible web browsers.
    Latest version at this moment is 0.3.1, and everything seems working.

    sudo add-apt-repository ppa:nilarimogard/webupd8
    sudo apt-get update
    sudo apt-get install freshplayerplugin

  3. Install Pepper Flash Player itself from Google Chrome Stable:

    sudo apt-get install pepperflashplugin-nonfree
    sudo update-pepperflashplugin-nonfree --install

    If you want, you can install flash player from different versions:

    Google Chrome Beta:

    sudo update-pepperflashplugin-nonfree --install --beta --unverified

    Google Chrome Unstable:

    sudo update-pepperflashplugin-nonfree --install --unstable --unverified

Now it's time to check version:

  1. Adobe About shows that I have 18,0,0,209
  2. about:addons shows that I have version 13.1 r2
  3. Mozilla's Check Your Plugins page shows that I have version 13.1.2.3, it's outdated and offers update now, but update doesn't work (and we don't need it, actually)
1

This is not Ubuntu only problem, cause the same message appears in FF on Mageia and openSUSE,

The solution is simple install a plugin for Pepper Flash for Firefox, SUSE team delivered a plugin last week, as soon as problem arised, so that on openSUSES flash is 16.0 like in Chrome

I hope there is a PPA for Ubuntu

http://www.webupd8.org/2014/05/install-fresh-player-plugin-in-ubuntu.html

p.s: the latest 11.2 flash is really outdated(vulnerable), changing version with apt-get wouldn't solve the problem

  • It is helpful to include the commands here in case the link breaks. Also, the 11. releases still receives updates for Linux distros, just not the new features (which is annoying) – Wilf Dec 25 '14 at 20:04
0

i currently can't reproduce your error, but this should solve your problem:

open a terminal and insert sudo apt-get update && sudo apt-get install adobe-flashplugin, type your root-password (no characters will be displayed), confirm the dialog and thats it!
well... maybe you have to restart your browser!

  • the latest flash version should be 11.2.202.425! – DJCrashdummy Dec 16 '14 at 12:54
  • if you have problems, have a look at this! – DJCrashdummy Dec 16 '14 at 13:03
  • 1
    ok... now i've got the same error! but i think it's a wrong check because you are still using flash 11.2 (on behalf of adobe no longer releases new versions for linux)! - i've done the mozilla check and also looked at adobe and both tell me i'm using the most recent version 11.2.202.425! so everything should be fine...! – DJCrashdummy Dec 16 '14 at 16:05
  • 1
    Why adobe-flashplugin instead of flashplugin-installer? – fikr4n Dec 17 '14 at 2:33
  • 1
    very well explained differences of the flash-packages! – DJCrashdummy Dec 17 '14 at 8:18
0
  1. Access https://get.adobe.com/flashplayer/
  2. Choose "Apt for Ubuntu 10.04+" in 'Your system:'
  3. Open with Software update application
  4. Install..

Forget the steps above ... It will update with an old version of the flash plugin. So it doesn't work. New working steps bellow :)

  1. Access https://get.adobe.com/flashplayer/
  2. Choose ".tar.gz for other linux"
  3. Wait until the download finishes
  4. Extract libflashplayer.so in the folder "~/.mozilla/plugins" for your user. For all users you have to extract to /opt/firefox folder (need root permission).

Did this last steps, I don't have these boring messages anymore.

  • after few days and plenty of different attemps from reading various forum posts - this works for me. [Linux xxxx 3.16.0-30-generic #40-Ubuntu SMP Mon Jan 12 22:06:37 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux] – harayz Jan 30 '15 at 4:18
-1

I had this problem on my laptop today, which I had upgraded at some point from Ubuntu 13.10.

It turns out the problem was that the adobe-flashplugin package had no updates, but this was due to the file /etc/apt/sources.list having a reference to saucy still for the partner repository. Editing this file and changing these instances of saucy in the file to trusty as they should have been on upgraded, and then running apt-get update && apt-get upgrade allowed the newer adobe-flashplugin package to get installed.

-2

The following procedure will deactivate the warnings for all plugins, since this error is because of a numbering problem of the flash-plugin as stated by DJCrashdummy you should follow it carefully, maybe reverting the change one month later or so once the flash-plugin get the correct numbering.

  1. In your address bar type: about:config
  2. Agree to void your warranty
  3. Right-click anywhere on the list below and select New > Boolean
  4. Copy-paste this phrase into preference name: extensions.blocklist.enabled
  5. The variable should be set to false by default, if it isn't on the list, double click it until it is.
  6. Reboot the browser

https://support.mozilla.org/en-US/questions/949746

-3

Have you tryed to type in this in the terminal:

  sudo apt-get install freshplayerplugin 
  sudo apt-get install pepper 
  sudo apt-get install adobe-flashplugin 
  sudo dpkg --reconfigure -a

and it might work fine this way.

protected by Community Oct 24 '15 at 22:11

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.