1

Did anyone else notice a sudden increase in booting time after a recent update (maybe, 2 or 3 weeks ago) in Ubuntu 14.04. After showing the Ubuntu logo, there is a black screen that takes a lot of time to finish. After that, Ubuntu loads the desktop and everything runs as usual.

This is happening in a laptop Dell Inspiron 1545 (Pentium 2GHz and 8GB RAM).

I have installed bootchart and this is the image produced:

enter image description here

If I'm reading the output correctly, it takes 1 minute and 28 seconds to load.

I'm almost certain that I haven't installed anything recently. Does anyone know what could be the cause?

UPDATE

It takes 55 seconds to show the black screen and lasts 43 seconds until the desktop appears. A few seconds before that, it is possible to move the cursor. It looks similar to the interval with low CPU use in the upper graph from the bootchart output.

  • What do you mean by it taking "a lot of time" to finish? Can you time a boot and find where it goes to the black screen? – Nattgew Dec 16 '14 at 21:50
  • Sure. I will update my question with that information. – Robert Smith Dec 16 '14 at 23:24
  • try as it is said in the link( from thegeekstuff website) I gave. start over if you cant find startup.log file – Edward Torvalds Dec 17 '14 at 4:45
1

Thanks for posting the boot chart. I'm no expert but I noticed these issues:

  • Toward the start of the boot, there's a fsck followed by a mount operation that is taking a long time (over 20 seconds). A fair bit of later stuff seems to be waiting for this operation.

  • Further on in the boot, there is what looks like gpu-manager running a "find" operation that is taking a long time. I don't know why this would be, but a fair bit of later stuff (including lightdm, the graphical desktop) is waiting on this to finish.

  • Thank you. Interesting. I'm a bit more concerned with the time it takes to show the desktop, since this became an issue right after a recent update. I don't think I did something to cause the behavior you described. – Robert Smith Dec 17 '14 at 1:27
1

All the files needed until you boot to desktop might be scattered or at-least away from start of the partition which happened while your system was getting upgraded, since new files are written to disk and after that old files are remove(of-course its done so that you can revert back if upgrade is not successful) this way new files are written away from start of partition. It takes more time to fetch those files. To reduce this time you have to reallocate the data back. I don't know a straight forward way to do this, but it can be done by installing e4rat(which is experimental). I tried e4rat recently on ubuntu 14.04 my boot time decreased by 10secs. if you want you can try from here

  • Thank you. That could be a contributing factor, but I'm more annoyed with the time it takes to show the desktop. Maybe, your suggestion is more focused on general improvement? – Robert Smith Dec 17 '14 at 1:29
  • @RobertSmith I think its the general improvement and its one time (at-least in several months) thing to do. Like you said after upgrade you had this problem, at the time of upgrade many files are written to disk before old files are removed, this is how your data/boot files got scattered. without try it you can do is remove some startup applications. besides this, after trying e4rat you can revert back.(but not need). It does show some improvement. one thing to note: after trying e4rat you have to record boot time by auto logging so that the delay of you entering password is not recorded – Edward Torvalds Dec 17 '14 at 1:41
  • I tried to run e4rat but for some reason, the file /var/lib/e4rat/startup.log is not created. Do you know if there are changes in the configuration procedure for Ubuntu 14.04? I'm following these instructions – Robert Smith Dec 17 '14 at 4:29
  • @RobertSmith as said in the link I gave in my answer(the link you gave me seems to be same as the one I gave, but try my link) if you dont have /var/lib/e4rat/startup.log you have to start all over. There is no change in procedure since I tried the same method on Ubuntu 14.04 myself 2 days ago. I recommend to repeat the procedure, but this time from the link I gave – Edward Torvalds Dec 17 '14 at 4:38
  • I already repeated the procedure 3 times, but I think e4rot can't write the file. I will try to change permissions. – Robert Smith Dec 17 '14 at 4:45
1

In my case it was a user issue:

I experienced the same problem, also on 14.04 installed on an ssd drive. It used to take 10 seconds to show a functional desktop and then it took 10 seconds to show a black screen with a pointer and another 30 seconds to show desktop.

Try to create another user and set this user to autologin. In my case it reduced boot time back to 9.5 seconds.

Now I will copy my old settings/files to new user. I 'll update if I reach to a safe conclusion.

UPDATE: I removed apport-gtk because I noticed an extreme CPU-usage during login and my system now behaves normally.

  • Thanks. Unfortunately, I have been using Ubuntu GNOME recently so I can't test your solution. In any case, let me know if that works. – Robert Smith Jan 19 '16 at 3:12
  • @RobertSmith You can test it. The only difference between Ubuntu and Ubuntu GNOME is the desktop environment, so same settings, same well, almost everything. – Star OS Jan 19 '16 at 8:16
  • I think the desktop environment has something to do with this bug because since I switched to Ubuntu GNOME, I don't have this issue anymore. – Robert Smith Jan 19 '16 at 19:50
  • I managed to have two concurrent Xservers running to monitor what was going on during the "slow" login. There were a lot of "apport-gtk" processes running with 11% cpu each so I uninstalled apport-gtk and the problem was solved. – John Jan 19 '16 at 20:22

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.