I have Ubuntu 14.10 with WinUSB and I have a Windows 8.1 Pro ISO with a 4GB SD Card with an empty FAT32 partition. Everytime I try to use it, it says "Installation failed, exit code: 256". How do I fix this?

  • also try sudo winusbgui in terminal .... – Aravinda Apr 28 '15 at 17:14
  • 2
    Open gparted, right click and select unmount. – sanz Dec 8 '16 at 10:01
  • 2
    Right click the usb drive, format NTFS worked for me! – pumpkin_cat Dec 27 '17 at 12:07

I started winusb from console:

gksudo winusbgui

then winusb detect my pendrive correctly, and I succesfully copied the Windows 7 installer to my pendrive (Ubuntu 14.10).

  • 1
    Without the sudo, the GUI prompts the user for administrative credentials, but ultimately fails. Running with sudo from the start works great. – Willi Ballenthin Jul 29 '15 at 17:05
  • 2
    The USB must be formatted to FAT32. Otherwise, I still get this error. To do that, open GParted, select the correct device from the drop-down, right-click the partition and unmount it. Then, right-click and format to FAT32. – Prinsig Jul 13 '16 at 9:24
  • 1
    I used gparted to unmount the pen drive. Right Click /dev/sdc/ -> hit unmount -> and went back to woeUSB to execute the installation – GatesReign Sep 16 '17 at 0:36
  • 2
    Same Issue on Ubuntu 18.04. Solution: Woeusb will try to use FAT32 by default so the windows 10 iso won't be loaded because some files are bigger than 4BG. Use the command line tool and add the --target-filesystem NTFS at the end. woeusb --device <iso_file> <device> --target-filesystem NTFS – Panos Dec 3 '18 at 13:25
  • The solution from Panos worked great for me. Thanks! – stidmatt Mar 25 '19 at 19:25

For some reason winusb kept hanging up on formatting the USB drive, said it couldn't access the drive. I ended up formatting to NTFS using the "Disks" application in Ubuntu and then using winusb from the terminal:

sudo winusb -v --install Win_7_Pro.iso /dev/sdc

NOTE: you can check to see what your usb device is using lsblk from a terminal, mine was sdc.

  • 3
    Thank you so much, this is the only thing that ran successfully for me. – conradkleinespel May 31 '16 at 21:04
  • Same here for Linux Mint! – Michel Jun 17 '16 at 21:11
  • I got an error using /dev/sdc, but got it right after figuring out it needed to be /dev/sdc1 (with a "1" at the end in my case). – heltonbiker Nov 26 '16 at 12:27
  • 3
    This should be an accepted answer. – Damir Olejar Dec 21 '16 at 3:43
  • It worked on ubuntu 18.04 and I used the gui right after I formated using "disks". – paulplusx Oct 1 '18 at 10:37

I faced the same error, and tried too many fixes until found the fix. Here is the fix in my case (I hope it works for you too):

  1. open GParted app then unmount the USB stick.

  2. open WinUSB or WoeUSB (a fork of WinUSB) and choose the .iso Windows file, and choose the USB stick. Everything goes right!

If you need to see the fix visually, I made a video on YouTube for the fix.


I just dealt with the same problem... Maybe it will help somebody:

I was getting this error when I clicked TARGET DEVICE and INSTALL, but if you click OPTIONS and SHOW ALL DEVICES and then you select your TARGET USB drive, it works... or at least it did in my case.

Of course my drive was formatted as NTFS!

EDIT: At the end of process error appeared, but Windows installation booted just fine.


If the Win8.1 is 64bit I understood (reading results from a Google Search) that you need at least 8GBs.

And obviously NTFS, not FAT. Indeed, I quote an excerpt From the help:

$ winusb --help
winusb usage
Install a windows ISO on an NTFS partition and edit MBR of the device

And from the CLI you can also ask for the verbose mode, maybe you can have more informations on the error.

  • The Win8.1 x64 iso is 3.7GB. I didn't think of NTFS. I'll try again. – kprovost7314 Jan 23 '15 at 16:23

You may have to format it as ntfs. Do sudo apt-get install gparted (skip this step if you already have it installed) then format it as ntfs.

sudo winusb -v --format Win10.iso /dev/sdb

This completely formats USB and installs iso image.

  • Please explain also which version of winusb you recommend, and how to install it. – sudodus Feb 18 '17 at 10:00
  • I used these way to install it: sudo add-apt-repository ppa:colingille/freshlight, sudo apt-get update, sudo apt-get install winusb – Stepan Pakholok Feb 25 '17 at 10:00
  • dpkg -l winusb returns version – Stepan Pakholok Feb 25 '17 at 10:06
  • Thank you :-) This shows that winusb from ppa:colingille/freshlight is working now. – sudodus Feb 25 '17 at 11:14

Not the answer you're looking for? Browse other questions tagged or ask your own question.