I cannot set default association of mp4 and avi files to my custom desktop files. For mkv, I can change from nautilus file>properties>open with tab. This is a video of the peculiar behavior that I am observing. It is hard to describe in words. Every time I click on my custom app in the 'open with' tab of file>properties in nautilus, and click on set as default, it reverts back.

This question has all the particular details of my specific case, but this seems to be a general problem as it is only for some file types . I need to associate all video files to my custom .desktop file. Please help.

I have tried:

  1. Changing the memetypes.list file.
  2. Changing defaults.list file
  3. Installed Thunar and tried setting association from there

All the attempts had the exact same results.

This might have something to do with the bug mentioned here


You probably need to change mimeapps.list: http://tuxdiary.com/2012/04/25/create-default-file-associations-manually-in-ubuntu-precise/

  • 1
    It turned out using system settings>details>file associations breaks mimeapps.list. Deleting the file and then avoiding that window forever is one way to bypass this. – thekindlyone Dec 16 '14 at 22:50

It is possible, that in your mimeapps.list there are duplicate mimetype association records for the file type (read: extension, such as .mp3).

This might not be obvious, because the records appear different. For example, both of the following records represent what to do for .mp3 files. The critical is the [Default Applications] section:

[Default Applications]

[Added Associations]

Both mime types audio/mpeg and audio/x-mp3 refer to the files of type ".mp3". Therefore the "open-with" system gets confused.

The solution: delete the equivalent mime types until only one remains. Or, delete all of them and reset the associations using only one tool of your choice.

The possible cause: assigning file associations by different tools, tweaks or by hand, using different mime type names for the same mime type.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.