2

I have a boot problem.

I've installed Kubuntu 13.10 from a standard image file (using the standard installer) without manual partitioning. During the set-up process I chose the option "Setup on entire encrypted LVM". I have two disks: hd0 (with a pre-installed Windows 8) and a new one hd1 with Kubuntu. After the installation completed, I rebooted and got the following message:

       [ Minimal BASH-like line editing is supported.   For
         the   first   word,  TAB  lists  possible  command
         completions.  Anywhere else TAB lists the possible
         completions of a device/filename. ]
grub>

I typed "reboot", then entered the BIOS, exiting without saving changes and I can now see a normal grub with listed options Kubuntu, Windows and so on.

I can successfully boot Kubuntu from it.

If I type ls in the minimal grub, it shows 6 partitions of hd0 and none on hd1. It seems GRUB started to see hd1 only after the BIOS preloads it somehow.

I also tried to modify grub.cfg adding instmod lvm but was unsuccessful, probably because GRUB resides on the LVM itself. I read several forum threads but even don't know how to classify this problem.

Could anyone help me?

Update. My configuration can be found here...

Update If I type exit in the minimal GRUB I get the normal GRUB.

Update Here is 'sudo parted --list' output here

3
  • For the future: you can use "`" (backticks) instead of <code> (less to type)
    – Fabby
    Commented Dec 16, 2014 at 1:03
  • Could you delete all your comments below the one that says "1"? Furthermore, do a sudo parted --list and post the output to a new paste.ubuntu.com
    – Fabby
    Commented Dec 16, 2014 at 21:49
  • Odd.. the fact that entering the bios or exiting from the minimal grub makes it work points to the disk simply needing extra time to work properly, but ls still not recognizing partitions on the drive after waiting a few seconds says otherwise. Either way, this is a problem with your hardware; possibly the disk, but most likely your bios.
    – psusi
    Commented Dec 17, 2014 at 0:57

1 Answer 1

1

Looking at your sudo parted --list output, you've put your boot partition onto the LVM... Bad idea! Head to The Linux Documentation project to read why you shouldn't...

boot is not included on the LV because bootloaders don't understand LVM volumes yet. It's possible boot on LVM will work, but you run the risk of having an unbootable system. [sic]

2
  • Thank you very much! It is really not the answer I'm looking for. Anyway I'm appreciated for you help. Can we make conclusion, that the option "Setup on entire encrypted LVM" in the Kubuntu installer works incorrectly? Can I move /boot to a separate partition on the working system or it will be simpler to full reinstall the system? What size of /boot will be sufficient without neccesity of regularly cleaning of kernel updates? Commented Dec 18, 2014 at 7:26
  • 5 years of not cleaning? 10 GB. better to re-install, create swap and /boot on a real partition, and the rest on LVM! ;-)
    – Fabby
    Commented Dec 18, 2014 at 18:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .