I have set up an Ubuntu 14.04 server with a Lubuntu front end in Virtualbox. I now want to configure two virtual servers on this system (something I have already done successfully on Windows). I just can't get it to work and am at my wits end. Help would be much appreciated. Here is what I have done:

1) To make sure the my requests were not going anywhere outside the Virtualbox, I switched off the Virtualbox network, now marked as "Not attached".

2) Checked the Apache server on http://localhostto make sure that Apache is up and running and able to serve a page. It works.

3) Modified /etc/hosts to include: economie. Tried ping -a economie. This works and shows IP address

4) Installed webmin and set up a Virtual Server called "economie" with the following characteristics:

 <VirtualHost *:80>
    ServerName economie
    ServerAdmin webmaster@localhost
    DocumentRoot /var/www/html/economie
    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined

5) Checked that the Virtual Server shows up in Webmin (it does)

6) Configured Firefox to use No Proxy

7) Try to navigate to http://economie. Firefox displays an error page "Server not found".

Please somebody, what on earth have I done wrong?

  • Could you test if adding economie www.economie in /etc/hosts fix your problem? Don't forget to press F5 to reload page.
    – Lety
    Dec 15, 2014 at 23:07
  • @Letizia Tried this - including completely deleting Firefox cache and also adding ServerAlias www.economie in the config file. Doesn't make any difference.
    – Martin K
    Dec 16, 2014 at 9:26
  • I got this to work by religiously following the instructions here. I realised in particular, looking at the default Apache page on localhost, that Apache seems to be set only to serve pages from a directory called public_html. Definitely a case of RTFM
    – Martin K
    Dec 19, 2014 at 13:23


You must log in to answer this question.

Browse other questions tagged .