54

What are the hotkeys for switching the current window between maximized, normal, and minimized states? If some of these don't exist, can I set them somewhere?

1

10 Answers 10

58

In Ubuntu 12.04 Unity the shortcuts can be found in:

System Settings | Hardware | Keyboard | Shortcuts | Windows.

In a default installation the keys are the following:

  • Maximize: Ctrl+Super+
  • Restore: Ctrl+Super+
  • Minimize: Ctrl+Alt+0 (the keypad 0)
7
  • 8
    Minimize doesn't work for me either with the "0" key on the top of the keyboard. It does work with the "0" key from the keypad, however. Aug 12, 2012 at 18:48
  • 2
    It does work with the "0" key from the keypad, however. Even when the Numlock is off. Quite wierd..
    – saji89
    Nov 30, 2012 at 5:52
  • I opened CCSM and found that Minimize is associated per default to <Control><Alt>KP0. not very useful on a laptop... luckily CCSM is meant for customizing this and more.
    – mariotomo
    Jun 27, 2013 at 13:25
  • 1
    Still applies to 14.04.
    – igordcard
    Apr 29, 2015 at 10:36
  • 8
    super + H works on 18.04 Dec 17, 2018 at 3:11
15
  • To minimise Alt+Space,N

  • To maximise Alt+Space,X

Depending on your internationalization settings the key to press after Alt+Space will be different (e.g. U to minimize with french settings).

2
  • This will minimize only current window. Is there anything to minimize all at once/
    – CR2
    Mar 3, 2014 at 9:08
  • ^ Super+D is what you are looking for..
    – Asim
    Aug 4, 2016 at 20:56
13

To minimize, it is not Ctrl+Super+0 but Ctrl+Alt+0.

It works on 12.04. Remember: Ctrl+Alt+0.

2
  • 1
    For me, control + super + D is minimizing showing the desktop. Again using it, restores the windows.
    – CR2
    Mar 3, 2014 at 8:31
  • 1
    Is there too a hotkey to restore the window?
    – tokam
    May 24, 2015 at 18:40
12

try Super + H in ubuntu to minimize the current window

2
  • Officially this is a "Hide" shortcut, there is no "minimize" in Unity anymore.
    – rustyx
    May 23, 2021 at 18:34
  • this works on 20.04 Feb 16 at 17:10
7

For Ubuntu 11.10 and earlier:

Alt+ F10 : Maximize the current window. If the window is already maximized, unmaximize it(normal).

Alt+ F9 : Minimize the current window.

2
  • 4
    This seems to stop working anymore. Aug 7, 2012 at 19:42
  • bagustrix's answer is the right one below.
    – galath
    May 28, 2013 at 12:06
4

If the defaults don't suit you, you can set new shortcuts by opening the Dash and searching for the app "Keyboard Shortcuts."

3

For Ubuntu 12 Unity:

Maximize: Ctrl+Super+

Restore: Ctrl+Super+

Minimize: Ctrl+Alt+0

Bottom-Left Corner: Ctrl+Alt+1

Bottom: Ctrl+Alt+2

Bottom-Right Corner: Ctrl+Alt+3

Maximize or Center: Ctrl+Alt+5

Top-Left Corner: Ctrl+Alt+7

Top: Ctrl+Alt+8

Top-Right Corner: Ctrl+Alt+9

2

On Ubuntu you can find your shortcuts in System Settings -> Keyboard -> Shortcuts. As well, you can show some shortcuts by holding the Super (Start) key.

In Ubuntu 15.10, it works with ctrl + alt + 0 (on the numberpad).

However, I prefer to use ctrl + super + arrow down key.

1

Strangely enough, in my Ubuntu 14.04 using KDE it's Alt + Middle Mouse Button.

Found in: Start->Computer->System settings->Window actions->Window behaviour

0

Fixed the minimize shortcut by changing the shortcut to Alt+M and now it works perfectly fine for me.

1
  • 2
    How did you change the shortcut? Could you add that to your answer please? Aug 12, 2012 at 18:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.