1

Testing my device's (nexus 4 running latest from devel-prosed) connection from SDK->Options->Devices->Test I get:

Connecting to host... SSH connection failure: SSH Protocol error:
Server and client capabilities don't match. Client list was:
aes128-cbc,3des-cbc. Server list was
aes128-ctr,aes192-ctr,aes256-ctr,aes128-gcm@openssh.com,aes256-gcm@openssh.com,chacha20-poly1305@openssh.com.

Device test failed.

However, $ phablet-shell connects successfully. My laptop is connected to my device via USB.

This worked five days ago. In the mean time I've updated both my device and my laptop. Any ideas how I can fix this?

7
  • You say "my device", what is this device? How are you connected to it? I assume it's a phablet, but that's as far as I got. – Robobenklein Dec 15 '14 at 15:35
  • My device is a Nexus 4 and the connection is via a USB cable. – Jonas G. Drange Dec 15 '14 at 17:23
  • I'm doing tons of Googling and not finding anything, but what you have to do is get one of those protocols installed on either the Nexus or your Computer. I would say that installing aes-ctr in your laptop would be the best bet. – Robobenklein Dec 15 '14 at 18:36
  • Yeah, I did some googling as well, but nothing substantial turned up. I have tried configuring both server and client configs to use the same set of capabilities, but your suggestion is good—I'll take a look. If you know how the SDK configures the ssh communication, let me know. That'd help. – Jonas G. Drange Dec 15 '14 at 19:09
  • 1
    @JonasG.Drange Just ticked 'affects me too' on the bug report... – alci Dec 18 '14 at 13:33
0

The above problem is fixed by installing Qt Creator 3.3.0.

https://qt-project.org/forums/viewthread/51072/

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.