3

I'm running Ubuntu 14.04 on lenovo yoga 13. Previously my wireless was working correctly, but only after running a script to fix the wireless:

cd /opt/rtl8723au-master
make clean
make
sudo make install
sudo modprobe 8723au 

This no longer works though. I recently had an update for a new kernel version. After updating I can no longer use the above script to connect to wireless. The script now eventually returns: Module 8723au not found

iwconfig: lo no wireless extensions

lspci -vvnn | grep Network: Nothing is returned

uname -a: Linux "computer-name" 3.13.0-43-generic #72-Ubuntu SMP Mon Dec 8 19:35:06 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

Also I would like to note this laptop does not have an ethernet port so I cannot connect to the internet at all.

If anyone has any suggestions that would be greatly appreciated, or if you need more info from me just let me know.

  • Please instead try: lspci -nn | grep 0280 Thanks. – chili555 Dec 15 '14 at 12:42
  • running lspci -nn | grep 0280 also resulted in no return values – user3521486 Dec 16 '14 at 6:37
  • We see no wireless device so far. How about: lspci -nn and also: lsusb. I wonder if your device has failed. – chili555 Dec 16 '14 at 13:59
  • lsusb: Bus 002 Device 004: ID 04f2:b322 Chicony Electronics Co., Ltd Bus 002 Device 003: ID 2047:0855 Texas Instruments Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 001 Device 006: ID 04f3:000a Elan Microelectronics Corp. Bus 001 Device 005: ID obda:1724 Realtek Semiconductor Corp. Bus 001 Device 004: ID obda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller Bus 001 Device 003: ID 04f3:02f4 Elan Microelectronics Corp. 2.4g Cordless Mouse – user3521486 Dec 16 '14 at 19:02
  • Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub Bus 001 Device 001: ID 1b6b:0002 Linux Foundation 2.0 root hub Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub – user3521486 Dec 16 '14 at 19:04
1

I had a similar problem recently. When the kernel gets update the headers for the driver also gets update. So we need the map the correct headers. I got a script similar to yours which worked for my driver. You can try to change the driver (from rtl8188eu to rtl8723au) and check whether thats helps you. Run the code below in terminal and reboot.

Here is script what worked for my driver

sudo apt-get update
sudo apt-get install linux-headers-$(uname -r)
sudo apt-get update
sudo apt-get install build-essential
sudo apt-get install git
sudo git clone https://github.com/lwfinger/rtl8188eu
cd rtl8188eu
sudo make all
sudo make install
sudo insmod 8188eu.ko
  • I ran the script up to the point of cloning the git repo. Since I do not have internet access I was unable to clone the repo. I don't have an ethernet port on my machine so that isn't an option unfortunately. Going to clone the repo on my other machine and copy it over, then I'll let you know how it goes – user3521486 Dec 16 '14 at 6:35
  • alright. I copied over the repo to my laptop. This was the result: sudo make all: make ARCH=x86 CROSS_COMPILE= -C /lib/modules/3.13.0-43-generic/build M=/home/"user"/rtl8188eu modules make[1]: Entering directory '/lib/modules/3.13.0-43-generic/build' make[1]: *** No rule to make taget 'modules'. Stop. make[1]: Leaving directory '/lib/modules/3.13.0-43-generic/build' make: *** [modules] Error 2 – user3521486 Dec 16 '14 at 6:44
  • sudo make install: install -p -D -m 644 8188eu.ko /lib/modules/3.13.0-43-generic/kerrnel/drivers/net/wireless/8188eu.ko install: cannot stat '8188eu.ko': No such file or directory make: *** [install] Error 1 sudo insmod 8188eu.ko: insmod: ERROR: could not load module 8188eu.ko: No such file or directory – user3521486 Dec 16 '14 at 6:46
  • side note, is there a better way for me to comment. I couldn't get the comment to obey new lines. That looks way trashy. First time actually asking a question on here hehe – user3521486 Dec 16 '14 at 6:47
  • Guess you forgot to change the driver. Try to replace rtl8188eu by rtl8723au in the script and give a check. – vembutech Dec 16 '14 at 7:17
0

This is your wireless device:

Bus 001 Device 005: ID obda:1724 Realtek Semiconductor Corp.

It is covered by 8723au. I suggest you try:

sudo apt-get install build-essential linux-headers-generic git
git clone https://github.com/lwfinger/rtl8723au.git
cd rtl8723au
make
sudo make install
sudo depmod -a
sudo modprobe 8723au

When Update Manager installs a later kernel version, recompile after the required reboot:

cd ~/rtl8723au
make clean
make
sudo make install
sudo depmod -a
sudo modprobe 8723au
  • I copied the git repo on another computer and transferred it over with a usb (since I do not have internet access). Then I ran everything with no error up to the make command (line 4 of your answer): make ARCH=x86 CROSS_COMPILE= -C /lib/modules/3.13.0-43-generic/build M=/home/"user"/rtl8188eu modules make[1]: Entering directory '/lib/modules/3.13.0-43-generic/build' make[1]: *** No rule to make taget 'modules'. Stop. make[1]: Leaving directory '/lib/modules/3.13.0-43-generic/build' make: *** [modules] Error 2 – user3521486 Dec 16 '14 at 21:15
  • You are in the rtl8188eu directory. My answer was for rtl8723au. – chili555 Dec 16 '14 at 21:17
  • sorry, I admittedly copy my comment from above since I am typing this out by hand without having access to the internet. I did actually run those commands using the rtl8723au directory. Sorry for the confusion – user3521486 Dec 16 '14 at 22:28
  • If you have no internet connection and therefore have no linux-headers-generic and no build-essential, the package will never compile. Downloading all those two packages and all of their dependencies will be a long, tedious process. If you install Ubuntu 14.10, the driver is included by default. – chili555 Dec 16 '14 at 22:36
  • Alright, I was debating this already. Since it seemed that somehow my headers how gotten messed up/corrupted after updating the kernel (not sure how or why, I did it on the computer I'm currently on without a hitch). I will upgrade my version from 14.04 to 14.10 and let you know how it goes. – user3521486 Dec 16 '14 at 22:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.