0

I could really use some help with troubleshooting my touch pad. I believe it is a hardware issue but I would like to be sure. Lenovo will not help me unless I have the original OS on the laptop... why would anyone leave Windows 8 on their pc on purpose?? Any way... I've looked at a few other posts, here is the output from the following command:

yogapro@yogapro:~$ xinput
⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ ELAN Touchscreen                          id=14   [slave  pointer  (2)]
⎜   ↳ Logitech USB Receiver                     id=12   [slave  pointer  (2)]
⎜   ↳ Logitech USB Receiver                     id=13   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Power Button                              id=8    [slave  keyboard (3)]
    ↳ Ideapad extra buttons                     id=9    [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=10   [slave  keyboard (3)]
    ↳ Lenovo EasyCamera                         id=11   [slave  keyboard (3)]

Also of note, when I run Ubuntu from a thumbdrive I am still unable to use the touchpad. Any suggestions? I appreciate the help!

3

1 Answer 1

1


I guess the Logitech USB Receiver is your wireless mouse?
I can't see any sign of your touchpad from the dmesg output, which should look like this if it works:

[ 10.706] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/event4)
[ 10.706] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "evdev touchpad catchall"
[ 10.706] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "touchpad catchall"
[ 10.706] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "Default clickpad buttons"
[ 10.706] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "touchpad catchall"
[ 10.706] (II) LoadModule: "synaptics"

Which means that the touchpad wan't detected by the kernel at all, this might be a bug or even a hardware failure.

I would suggest you to give 14.04 a try (live desktop is fine), since it seems that the touchpad on Yoga 2 Pro works fine with 3.13 kernel from this bug report on launchpad:
On Lenovo Yoga 2 Pro laptop PS/2 Synaptics TouchPad detected as pointer device by Xorg.

If it's a bug in 3.16 kernel, please report it with ubuntu-bug linux command in your terminal, and you can follow the detailed debugging instruction from this wiki page.

Good luck!

1
  • I ran 14.04 live and still no sign of the touchpad. Not super surprised but a little bummed. Honestly the quality of this yoga 2 pro leaves a lot to be desired. Now I have to install windows back on here or Lenovo won't try to repair it. Thank you for your help!!!
    – spidiracer
    Dec 17, 2014 at 2:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.