3

I am very new to Linux, so please forgive me if the answer to my question is obvious. Since I am running an ARM device and can't install wine, I am trying to install Mono/Develop. The problem is, whenever I try to install any of the Mono packages, I am greeted with a huge block of "unmet dependencies." For example:

(precise).....@localhost:~$ sudo apt-get install monodevelop
.
.
.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
.
The following packages have unmet dependencies:
 monodevelop : Depends: mono-runtime-sgen but it is not going to be installed
               Depends: mono-runtime (>= 3.0~) but it is not going to be installed
               Depends: libgconf2.0-cil (>= 2.24.0) but it is not going to be installed
               Depends: libglade2.0-cil (>= 2.12.10-1ubuntu1) but it is not going to be installed
               Depends: libglib2.0-cil (>= 2.12.10-1ubuntu1) but it is not going to be installed
               Depends: libgnome-vfs2.0-cil (>= 2.24.0) but it is not going to be installed
               Depends: libgnome2.24-cil (>= 2.24.0) but it is not going to be installed
               Depends: libgtk2.0-cil (>= 2.12.10-1ubuntu1) but it is not going to be installed
               Depends: libmono-cairo4.0-cil (>= 3.2.1) but it is not going to be installed
               Depends: libmono-corlib2.0-cil (>= 3.2.8) but it is not going to be installed
               Depends: libmono-corlib4.5-cil (>= 3.6.0) but it is not going to be installed
               Depends: libmono-microsoft-build-engine4.0-cil (>= 3.2.1) but it is not going to be installed
               Depends: libmono-microsoft-build-framework4.0-cil (>= 3.6.0) but it is not going to be installed
               Depends: libmono-microsoft-build-utilities-v4.0-4.0-cil (>= 3.6.0) but it is not going to be installed
               Depends: libmono-microsoft-csharp4.0-cil (>= 1.0) but it is not going to be installed
               Depends: libmono-posix4.0-cil (>= 3.2.3) but it is not going to be installed
               Depends: libmono-sharpzip4.84-cil (>= 1.0) but it is not going to be installed
               Depends: libmono-system-componentmodel-dataannotations4.0-cil (>= 3.2.3) but it is not going to be installed
               Depends: libmono-system-configuration4.0-cil (>= 1.0) but it is not going to be installed
               Depends: libmono-system-core4.0-cil (>= 3.2.8) but it is not going to be installed
               Depends: libmono-system-data-services-client4.0-cil (>= 1.0) but it is not going to be installed
               Depends: libmono-system-data4.0-cil (>= 3.0.6) but it is not going to be installed
               Depends: libmono-system-design4.0-cil (>= 1.0) but it is not going to be installed
               Depends: libmono-system-drawing4.0-cil (>= 3.0.6) but it is not going to be installed
               Depends: libmono-system-runtime-serialization4.0-cil (>= 1.0) but it is not going to be installed
               Depends: libmono-system-runtime4.0-cil (>= 2.10.1) but it is not going to be installed
               Depends: libmono-system-security4.0-cil (>= 1.0) but it is not going to be installed
               Depends: libmono-system-servicemodel4.0a-cil (>= 3.2.3) but it is not going to be installed
               Depends: libmono-system-web-mvc3.0-cil (>= 1.0) but it is not going to be installed
               Depends: libmono-system-web-razor2.0-cil (>= 1.0) but it is not going to be installed
               Depends: libmono-system-web-services4.0-cil (>= 1.0) but it is not going to be installed
               Depends: libmono-system-web-webpages-razor2.0-cil (>= 1.0) but it is not going to be installed
               Depends: libmono-system-web4.0-cil (>= 2.10.3) but it is not going to be installed
               Depends: libmono-system-windows-forms4.0-cil (>= 1.0) but it is not going to be installed
               Depends: libmono-system-xaml4.0-cil (>= 1.0) but it is not going to be installed
               Depends: libmono-system-xml-linq4.0-cil (>= 3.0.6) but it is not going to be installed
               Depends: libmono-system-xml4.0-cil (>= 3.6.0) but it is not going to be installed
               Depends: libmono-system2.0-cil (>= 3.2.1) but it is not going to be installed
               Depends: libmono-system4.0-cil (>= 3.2.8) but it is not going to be installed
               Depends: libmono-windowsbase4.0-cil (>= 3.0.6) but it is not going to be installed
               Depends: monodoc-base (>= 3.2.1) but it is not going to be installed
               Recommends: libglade2.0-cil-dev but it is not going to be installed
               Recommends: libgtk2.0-cil-dev but it is not going to be installed
               Recommends: mono-devel but it is not going to be installed

And at the end, I get this error:

E: Unable to correct problems, you have held broken packages.

The same thing happens when I try installing other packages such as mono-complete, but to a lesser extent.

(precise).....@localhost:~$ sudo apt-get install mono-complete
.
.
.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
.
The following packages have unmet dependencies:
 mono-complete : Depends: mono-runtime (= 2.10.8.1-1ubuntu2.2) but it is not going to be installed
                 Depends: mono-runtime-sgen (= 2.10.8.1-1ubuntu2.2) but it is not going to be installed
                 Depends: mono-utils (= 2.10.8.1-1ubuntu2.2) but it is not going to be installed
                 Depends: mono-devel (= 2.10.8.1-1ubuntu2.2) but it is not going to be installed
                 Depends: mono-mcs (= 2.10.8.1-1ubuntu2.2) but it is not going to be installed
                 Depends: mono-gmcs (= 2.10.8.1-1ubuntu2.2) but it is not going to be installed
                 Depends: mono-dmcs (= 2.10.8.1-1ubuntu2.2) but it is not going to be installed
                 Depends: mono-csharp-shell (= 2.10.8.1-1ubuntu2.2) but it is not going to be installed
                 Depends: mono-2.0-gac (= 2.10.8.1-1ubuntu2.2) but it is not going to be installed
                 Depends: mono-4.0-gac (= 2.10.8.1-1ubuntu2.2) but it is not going to be installed
                 Depends: mono-2.0-service (= 2.10.8.1-1ubuntu2.2) but it is not going to be installed
                 Depends: mono-4.0-service (= 2.10.8.1-1ubuntu2.2) but it is not going to be installed
                 Depends: monodoc-base (= 2.10.8.1-1ubuntu2.2) but it is not going to be installed
                 Depends: monodoc-manual (= 2.10.8.1-1ubuntu2.2) but 3.10.0-0xamarin2 is to be installed
                 Depends: libmono-cil-dev (= 2.10.8.1-1ubuntu2.2) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I have tried following the instructions on http://www.howtogeek.com/howto/linux/installing-monodevelop-from-source-on-ubuntu/, on Mono-Project, and MonoDevelop, and running sudo apt-get update, but I keep getting that broken packages error.

Do I have to reinstall Ubuntu (which is fine with me, since I'm using Crouton), add all of those package names to sudo-apt-get install, or what?

1

I had similar problem, try installing monodevelop with aptitude (instead apt-get). I am not running arm but maybe it can help. If u don't have aptitute install it with apt-get (sudo apt-get install aptitude).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.