19

After upgrading from xubuntu 13.10 to 14.04, I found that dropbox needed re-installation on my system, amongst a slew of other problems. I performed the following as suggested here:

sudo rm -rf /var/lib/dropbox/.dropbox-dist
dropbox start -i

EDIT: as this had failed to resolve the problem described below, I have also tried to install Dropbox from the .deb from here for Ubuntu.

This has installed dropbox version 3.2.9 which appears to be working again, however the notifier icon in the xfce4-panel does not abide by the locally set theme/icons:

dropbox icon not abiding by elementary-xfce-dark theme

Here, I am using elementary-xfce-dark, and can confirm that the Dropbox status icons I want to use are present in /usr/share/icons/elementary-xfce-dark/panel.

However, the icons actually being used (~/.dropbox-dist/dropbox-lnx.x86_64-3.2.9/images/hicolor/16x16/status) are PNG files with transparency, however on inspection the background is #EFEBE7, which suggests the alpha channel is being used, and something else is setting this as the background color.

UPDATE

On occasion, the Dropbox icon doesn't appear in the xfce4-panel at all after a reboot, either in the notification area, or the system tray.

PARTLY RESOLVED

So, err, after purging then re-installing Dropbox from here using the .deb package, I now intermittently see this after each hard reboot:

Correctly using background color with Dropbox icon image

Here's a list of everything I can remember I did before the hard reboot:

  • Installed the following:
    • libappindicator1 (tried because of these tips, found it was already installed);
    • libappindicator3-1 (was not already installed)
    • libappindicator3-dev (was not already installed)
  • Followed the tip from here which disables auto-start of the indicator-application-service at login (called 'Indicator Application' in the 'Session and Startup'/'Application Autostart' menu);
  • Sacrificed several goats.

I can confirm that:

  • The running version is being invoked from ~/.dropbox-dist/dropbox-lnx.x86_64-3.2.9/;
  • The dropbox icon appears in the notification area, not the system tray, of the xfce4-panel;
  • $ python --version produces Python 2.7.6

I'm uncertain as to precisely which, if any, of the above steps were necessary to affect the appearance of the icon. Again, disappointingly, the icon only appears intermittently -- once out of every few shutdown/boot cycles, so YMMV!

I also note that when it is present, the icon(s) and theme/style being used are still not consistent with the locally set theme. For example, check out the tooltips :

dropbox 3.0.3 tooltip not using local theme ...versus... bluetooth notification area icon using local theme


PROGRESS NOTES

  • There appears to be chatter about this problem here, and here, suggesting that the latest version of dropbox (3.0.3) now uses the Qt UI. The behavior of dropbox 3.0.3 to ignore local themes also seems to apply to other linux distributions such as Mint and Arch.
  • This page suggests that xfce4 had a bug which did not permit Qt5 software from using the local theme. However, upgrading to xfce4-session version 4.11 has not solved the problem.
  • I'm about to embark on a fresh install of xubuntu 14.0.4-1 to address other issues, so I'll report back here as to whether the problem persists.
  • After installing a fresh version of xubuntu 14.04-1, I now see no dropbox notification icon at all! I presume that if I find a way of activating it again, I might still have the same problem. I'll keep on it...
  • Trying out various installation options (deb files from the dropbox website, compiling and installing from source) has not yielded any solution yet. Suggestions welcome!
  • 1
    Part of the problem can be solved by putting copies of your desired icons in ~/.dropbox-dist/dropbox-lnx.x86_64-3.0.3/images/hicolor/16x16/status. Others have complained about the "white square" background, but I don't have that problem. Fixing the dropdown looking different could be done during the qt4 era with qt4-qtconfig. I don't know what works now. In any case, I'm not going to bother with that aspect because I don't use any other qt apps currently and don't rely on the Dropbox dropdown enought to get inconvenienced. – DK Bose Dec 15 '14 at 1:40
  • Thanks @DKBose -- I've already done that (copied over the right icons) -- but I'd like it to use the local theme to avoid the white background, too. I'm now suspecting this is a bug with the latest release (3.0.3). – sharky Dec 15 '14 at 1:42
  • 1
    I've posted my icons in the crunchbang link so that others could try it but they haven't got back as yet. There are other oddities with this Dropbox update but let's give the devs some time to fix things. After all, unlike Google, Dropbox is doing something for Linux desktop users. – DK Bose Dec 15 '14 at 1:46
  • This doesn't do anything for the dropdown. My ~/.config/Trolltech.conf already had the two lines. Another qt4>qt5 issue. – DK Bose Dec 15 '14 at 1:57
  • 1
    Same issue here. To be frank, I've gotten quite annoyed with Dropbox' antics lately. The daemon has a pretty significant performance and memory footprint on my system. Add to this these new cosmetic issues and I think I am done with autostarting Dropbox. If you are looking for a different solution check out this dropbox sync script. You can use it to perform a one-time sync. No need to have the ugly daemon running permanently. – Glutanimate Dec 17 '14 at 12:35
6

So, no complete answer in over two months?

enter image description here Allllllll-righty then!

Now presenting... my ever-so-embarrassing, not-really-to-be-recommended, disgustingly cringeworthy hack:

  • Find your notification icons in the .dropbox-dist directory, which might be in ~/.dropbox-dist or /var/lib/dropbox/.dropbox-dist. Inside this, the icons are in the folder dropbox-lnx.x86_64-3.2.9/images/hicolor/16x16/status (or similar, your path may differ depending on the version and build used).
  • Determine the colour of your xfce4-panel. This is easy using a tool like Gimp with the colour picker tool (enter image description here). Mine happens to be #242424.
  • For each of the notification icons which are PNG images with transparency, open them with Gimp. Yes, that's right folks, I'm going to change that background from transparent to a solid color (in my case, #242424). *Hangs head in shame.*

The result:

enter image description here

enter image description here

Looking good. This is perfectly fine for me, as I don't change the xfce4-panel color. However, some things to note:

  • You'll need to restart dropbox for the change to take effect:
    • ~$ dropbox stop
    • ~$ dropbox start
  • If you edit the stock 16x16px icons, you might find them centred with a 2px #EFEBE7 border if your icons are 22x22px. I addressed this by simply enlarging the icons to my required size (22x22px).
  • If Dropbox is ever updated, your icons might be blown away. If you're going to try this yourself, keep a backup copy of your icons outside the Dropbox directory. Or, you can just download them from here (if you also use #242424 for your panel color):

  • dropboxstatus-logo.png (dropboxstatus-logo.png)

  • dropboxstatus-idle.png (dropboxstatus-idle.png)
  • dropboxstatus-busy.png (dropboxstatus-busy.png)
  • dropboxstatus-busy2.png (dropboxstatus-busy2.png)
  • dropboxstatus-x.png (dropboxstatus-x.png)
  • 2
    Instead of manually adjusting each image you can use the command for i in *.png; do convert $i -background '#000000' -alpha remove $i; done replacing #000000 with the correct color code for your panel. Note that this overwrites the images, so you may want to back up the icons first! – Laurence Gonsalves Apr 14 '15 at 19:02
  • @LaurenceGonsalves sweeeet. – sharky Apr 14 '15 at 23:19
  • This solution is ok I used it to change the white areas to a darker color, but then when dropbox is updated it changes the images back. It's very annoying specially because IT'S IMPOSSIBLE TO PREVENT DROPBOX TRAY ICON CRA*PY PROGRAM FROM UPDATING. Why is that? Because you don't even have the freedom to use the program. That's why I love Free Software! I use dropbox because of some work reasons that cannot be avoided (I hate to be forced to use it). – iharob Aug 20 '15 at 20:59
5

If you disable compositing and then do a restart, the icon shows up in the tray bar. Sadly, that's not a solution for me, as I need compositing.

To disable compositing in Xubuntu 14.04:

  • Go to "All settings" and click on "Window manager tweaks":

enter image description here

  • Go to the tab "Compositor"
  • Uncheck the "Enable display compositing" option

enter image description here

PS: I should've probably added this in the comments instead, but I cannot comment yet, not enough rep. points (stupid rule).

  • Hopefully someone can use this to create a real solution! – iamatrain Dec 22 '14 at 12:10
  • Cool, thanks. Disabling compositing reveals the Dropbox icon, but on my machine it still isn't abiding by the locally set theme, and looks like this. At least I can now access the context menu where I couldn't before! – sharky Jan 4 '15 at 22:05
1

This is an automated version of sharky's answer. First, create a script called fix-dropbox-icons:

#!/bin/bash
find $HOME/.dropbox-dist/ -name '*.png' -exec \
    convert \{} -background '#000000' -alpha remove \{} \;

If your background is some color other than black then adcjust the #000000 bit accordingly. Don't forget to chmod +x this script.

In your startup (.xsession, .Xinit, .i3/config, DE settings... depends on your setup) make it run this script at startup/login. If dropbox updates and restarts while you're logged in the icon will be temporarily messed up, but the next time you log in it should be fixed again.

-1

in mint17.1 I uninstalled dropbox and installe Nemo Dropbox in synaptic and the icon showed up in the system tray, on using these keys on the keyboard ctrl, alt, back space - to reset

-1

XUBUNTU 14.04.1 kernel 3.13.0-44

I used the bash -c "dropbox stop && sleep 5 && strace ~/.dropbox-dist/dropboxd 2>/dev/null >/dev/null" script above and it restored the notification icon. However, it disappeared again when I closed the terminal or broke out using CTRL-C.

I put the script in my startup programs with the -D switch and rebooted. Now, the icon shows up permanently.

bash -c "dropbox stop && sleep 5 && strace -D ~/.dropbox-dist/dropboxd 2>/dev/null >/dev/null"

Hope this helps...

-1

This is how I completely solved after many attempts. I hope it will be usefull also for someone else:

  • uninstalled dropbox from applications manager
  • deleted the dropbox-automatic-boot line into settings/session-start
  • disabled composite manager (by uchecking its box)
  • rebooted
  • re-installed dropbox from the terminal:

    cd ~ && wget -O - "https://www.dropbox.com/download?plat=lnx.x86_64" | tar xzf -
    
  • manually created a new dropbox-automatic-boot line into settings/session-start with this new path:

    /home/my_home/.dropbox-dist/dropbox-lnx.x86_64-3.2.6/dropbox
    
  • rebooted and eventually re-enabled composite manager
  • Does this fix the issue with the icon not abiding by local themes? – sharky Feb 16 '15 at 22:12
-2

The compositing thing works erratically for me, without doing a restart. If you keep clicking the enable/disable checkbox sometimes it reappears.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.