1

I'm running 14.04 LTS with ZFS and tried to update my kernel to 3.17 following these instructions. During this install I got this error:

    *** Please make sure the kmod spl devel <kernel> package for your
    *** distribution is installed then try again.  If that fails you
    *** can specify the location of the spl objects with the
    *** '--with-spl-obj=PATH' option.

Google led me to this page, and I ran sudo apt-get install spl-dkms to attempt to fix the above.

After reboot, I have kernel 3.17 but no ZFS pools. I rolled back to my previous kernel (3.13.0-40) but still have no zpools.

$ sudo zpool status
no pools available

I should have one mirror pool showing. The partitions are still there, as parted shows:

(parted) print                                                            
Model: ATA HGST HTS721010A9 (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt

Number  Start   End     Size    File system  Name    Flags
 1      1049kB  2097kB  1049kB               boot0   bios_grub
 2      2097kB  10.0GB  9998MB               root0
 3      10.0GB  992GB   982GB   zfs          zdata0
 5      992GB   1000GB  8204MB               swap0

The other drive looks similar. The mirror is on zdata0 and zdata1.

Why can't it find my zpool, and how do I get it back?

6

In this case, zdb showed the pool, but zpool status did not. I needed to do:

zpool import -f zdata

And all was well again.

  • Yes, but after reboot, zpool will disappear again. – Xdg Nov 24 '15 at 9:18
  • @Xdg, didn't in my case. Working fine ever since. – ScottJ Nov 24 '15 at 22:55
  • Thanks. You were on 14.04. In 15.10, I had to add zpool import tank into /etc/rc.local . – Xdg Nov 25 '15 at 6:10
  • This worked great on 16.04. I shutdown and removed two drives, upon reboot the pool was completely missing, very odd. This fixed my issue though. – Casey Weed Aug 11 '16 at 19:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.