I currently have a dual-boot system with Windows 8 and Ubuntu 14.04, on separate hard disks. I have installed the Grub bootloader using the Boot-Repair tool; however, it seems that whenever I boot into Windows my bootloader gets overwritten so that the next time I reboot, Grub doesn't appear - the system just boots straight into Windows. So ... I have to get out my Ubuntu live USB and use Boot-Repair to reinstall Grub each time, which is getting a bit tedious.

I have disabled automatic updates in Windows, as I suspected the updates were overwriting the bootloader. However, this now seems to be happening just by me booting into Windows. Has this happened to anyone else and does anyone know how I can prevent Windows from telling me what bootloader to use?

Thanks!

Edit 12/14/14: I've just verified that secure-boot is disabled in the BIOS - that doesn't seem to be affecting the problem. I also just ran Boot-Repair, which fixed Grub, and then booted back into Windows. The same problem happens: when I reboot after that it bypasses Grub and boots straight into Windows.

up vote 1 down vote accepted

Ok, I think I've figured it out. I just followed the instructions on the screen that Boot-Repair prints after it's finished (I tried to post an image but don't have enough reputation).

Anyway, I first tried changing the boot order and that didn't work (the only option it showed in the BIOS for HDD boot was Windows EFI boot). So, I tried the typing the following command in the Windows command prompt (as recommended by Boot-Repair):

bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi

and that worked - now it goes into Grub if I restart from Windows. I guess that command tells Windows to use Grub as it's bootloader ...

Is secure boot turned on in your BIOS settings?

Maybe you have secure boot turned on in your BIOS - it is actually a feature in UEFI based systems that keeps your boot safe from infections, editing etc. Try turn this off in your BIOS settings (On HP laptops it is usually F10 -> System configurations -> boot settings).

Check this link: http://www.eightforums.com/tutorials/17058-secure-boot-enable-disable-uefi.html

enter image description here

  • Hi guyromb, I have already turned off secure-boot in the BIOS settings. I did that when I first set-up the dual-boot. Thanks for trying though! :-) – Time4Tea Dec 14 '14 at 20:09

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.