1

I'd like to build Celestia-1.6.1 on my Ubuntu 14.04 machine however, it seems that I can't do that easily with the gcc version 4.9.1.

I'm using source files from http://sourceforge.net/projects/celestia/files/

Running ./configure --with glut works:

***************************************************************
** Celestia configuration complete. Now do a 'make' followed **
** by 'make install'                                         **
***************************************************************

Front-End: GLUT
Use Lua: yes
Use Theora: auto

Then I got errors when running make, two that can be solved:

  1. #include "mathlib.h" in file intersect.h
  2. #include <cstddef> in file frametree.h

However I can't fix the last error:

/usr/bin/ld: ../celengine/libcelengine.a(libcelengine_a-glext.o): undefined reference to symbol 'dlclose@@GLIBC_2.2.5'
/usr/lib/gcc/x86_64-linux-gnu/4.9/../../../x86_64-linux-gnu/libdl.so: error adding symbols: DSO missing from command line
collect2: error: ld returned 1 exit status

Does anyone have succeed doing this build?

1
  • 1
    Why not just install Celestia from the repos? Version 1.6.1+dfsg-3 is in the "universe" repo. You may need the build-dep for it to build it, but I'd just apt-get install celestia – Xen2050 Dec 14 '14 at 16:07
2

I would recommend that you use the latest sources from SVN. Celestia 1.6.1 is quite old. Celestia 1.7 was never released, but it was close to being released. There is no development at the moment in Celestia SVN.

The recommended UI for Celestia 1.7 is QT4. Makefile for building this UI is generated with qmake, not with GNU autotools.

Edit celestia.pro.

run qmake
and make

More details at: http://en.wikibooks.org/wiki/Celestia/Development/Qt4

Because the development in the official SourceForge SVN is dead, I have just started a git repo with the latest Celestia sources: https://github.com/bgodard/celestia-g2 . It includes a patch which adds a new feature to Celestia.

If you really want to build Celestia 1.6.1, you might want to get the source package from the Ubuntu repo and see which patches might have been applied to have it compile with recent gcc versions.

1
  • Thank you, the build worked using a clone of your github repository with ubuntu 14.10. I also needed to install cspice from source as described in the Celestia Wikibook – Ben Dec 14 '14 at 19:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.