I have NVIDIA GTX 970 GPU, which is pretty new chip and it is not recognized by nouveau driver shipped with Ubuntu 14.10, hence I am stuck on 1024x768 resolution on Full HD monitor - not so good. There is no proprietary driver in Additional Drivers setting, so I decided to download and install driver directly from NVIDIA web site.

I tried to install NVIDIA driver exactly like I did ten years ago on Slackware:

$ sudo ./NVIDIA-Linux-x86_64-343.36.run

but it says, that it must be run without X Server running. Ctrl+Alt+F1 (or combination with any other F? key) takes me to the black screen and only thing I can do then is to return back to X by Alt+F7.

My next step was to tune GRUB to boot into pure text mode. I edited /etc/default/grub to have:



$ sudo update-grub

and reboot, system hangs during boot on some video mode stuff.

My question is: how to run a pure VGA text mode? No famebuffer, no fancy splash, just pure ASCII 80x24 text? I need it only once, just to install NVIDIA driver and have 1920x1080 screen resolution.


I also tried to install NVIDIA driver from Ubuntu repository:

$ sudo apt-get install nvidia-331

No success, it made my system unusable with graphics totally messed up.


5 Answers 5


Nvidia 343.22 added support for GeForce GTX 970 and GTX 980. It's not available in the official repositories.

This repository is meant to be used only for testing, not on daily basis, please make sure to read the following link to understand the risk.


and follow the instruction on the above link as this PPA clearly states that no installation instructions shall be given for this PPA outside of their website!


  • 1
    Your answer solved my problem, now everything works like a charm. Thank You!
    – user280493
    Dec 31, 2014 at 19:20
  • 5
    is that safe to do? the ppa description explicityl states that one should NOT use this to install single packages from it becaus it should be used as "whole". Jan 8, 2015 at 14:23
  • 2
    Any update on this? It's been almost a year since this question was answered and I would think Ubuntu support for this chipset has evolved since then.
    – Coder Guy
    Oct 16, 2015 at 7:07
  • I found a way to google the nvidia drivers like: "linux" "em64t" "GTX 970M" site:nvidia.com/en-us/drivers/results
    – Martin
    Jul 27, 2021 at 20:05

I had the same problem as you and, I found out the only way to fix this problem was to install the third-party driver and then config blacklist option. Then you can remove the third-party driver and install the official driver from Nvidia. I recommend the beta since it has better support, but if you want you can use, the 343 instead of 346 beta. Both worked fine for me.

This worked fine for my MSI Gaming GTX 970 4G. The NVIDIA .run file can be found in at:

Installation Guide

  1. This is only for getting the system running ready for the .run installation so it doesn't go to a black screen when you try to enter tty, also known as CLI mode.

    Press Ctrl+Alt+T to open the terminal and run the following commands:

    sudo add-apt-repository ppa:xorg-edgers/ppa
    sudo apt-get update
    sudo apt-get install nvidia-343
    sudo reboot
  2. Remove or disable the ppa:Xorg-edgers/ppa repository from /etc/apt/sources.list

  3. Install build essential compiler, dmks, gcc and leafpad for editing and gksu for graphical applications.

    sudo apt-get install linux-headers-$(uname -r) build-essential dmks gcc gksu leafpad
  4. Configure blacklist for the NVIDIA.run driver

    Command for leafpad:

    gksu leafpad /etc/modprobe.d/blacklist.conf 

    The required listing at the bottom of the blacklist.conf file:

    blacklist amd76x_edac  
    blacklist vga16fb  
    blacklist nouveau  
    blacklist rivafb  
    blacklist nvidiafb  
    blacklist rivatv  
  5. Go into tty or console terminal shell:

    Press Ctrl+Alt+F1 and login using your credentials.

    Command to remove nvidia: (if needed, recommended when updating or else you have 2 NVIDIA drivers resulting in a system black screen or sometimes a hardware fail.)

    sudo apt-get remove --purge nvidia* 

    Do not reboot after this step.

  6. Command to stop lightdm: (required)

    sudo service lightdm stop  

    Command to get to your Downloads folder: (or wherever you put it. I recommend at your home folder, then the following command is unnecessary.)

    cd ~/Downloads   
  7. Command for changing the permissions of the NVIDIA installer so that the installer will run:

    chmod u+x [Nvidia installer here].run   
  8. Enter run level 3 by typing: (Graphical driver install might need this. You need it in Fedora and most Linux distros.)

    sudo init 3  
  9. Install your Nvidia-driver*.run file.

    sudo ./[Nvidia installer here].run  or sudo sh [Nvidia installer here].run 

    Accept the license and all other programs and code that it will install, especially 32-bit lib and start installation.

  10. Restart lightdm

    sudo service lightdm start   

    to test if all still works.

  11. Reboot

    sudo reboot   

Now, check in System -> Preferences -> NVIDIA X Server Settings.

I tried this myself on 4 computers, and it also works with Fedora, but some commands must be changed. It worked fine for me and my friends.

  • You are a bit late with your answer, but please clean it up (capitalization, formatting, spelling) anyway, it can be useful in the future. I will give You a +1 if you do so ;-).
    – user280493
    Dec 31, 2014 at 19:36
  • Very good advice if (like me) you find that you can't get a console outside the X server unless the drivers are installed. However, nvidia-343 is no longer available from xorg-edgers. I was able to install nvidia-346 instead, then follow the instructions to get a console, remove the PPA and run the NVIDIA installer. Feb 1, 2015 at 21:14
  • "build-essential dkms gcc gksu leafpad" isn't it? Mar 12, 2015 at 14:17
  • It's like always... Nvidia graphics driver installing brings hell right up into my house. Linux is the biggest GARBAGE. On Windows: click next, next, next, finishhhh. DONE & WORKS! Mar 12, 2015 at 14:58
  • "It's like always... Nvidia graphics driver installing brings hell right up into my house. " Don't be a moron and a Windows schill. There are very few problems with NV and Linux compared to AMD or Intel and performance is exemplary. Unlike AMD, you don't have to wait 18 months to get a regressive, bug-filled driver that supports your "new" GPU. I've run 970 since release on Kubuntu with very few problems. Apr 18, 2015 at 18:54

Using the .run file will crash your system. Just install the package

sudo apt-get install nvidia-331

The "Additional Drivers" menu can't recognise a lot of hardware so that means nothing. The Ctrl+Alt+F1 should have been working. It is a separate problem for you to solve after you deal with drivers.

  • I edited my answer, please take a look. Thank you.
    – user280493
    Dec 14, 2014 at 19:38

I tried sudo-apt get install nvidia-331 (and nvidia-current) on my Asus laptop with the 970M, but those drivers do not yet recognize this GPU. So it left my system running in low-res mode, even after removing the packages. I plan to try running the installer:

Ctrl+Alt+F1 to get into console mode.

sudo service lightdm stop

Then run the package.


I was getting a blank screen in a laptop with a 970m, Ubuntu 14.10.

I had installed the nvidia .run driver file and to get rid off a blank screen hang on boot I had to add nomodeset to kernel boot options. I just downloaded the driver from nvidia and installed it from a text terminal with:

sudo service lightdm stop (kill x server)
cd ~/Downloads
chmod +x NVIDIA-Linux-x86_64-346.35.run
sudo ./NVIDIA-Linux-x86_64-346.35.run