I am using an HP product with wireless lan interface details as follows-

sudo lshw -c network
  *-network               
       description: Wireless interface
       product: BCM43142 802.11b/g/n
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:08:00.0
       logical name: wlan0
       version: 01
       serial: 14:2d:27:d2:94:0f
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=wl0 driverversion=6.30.223.141 (r415941) ip=192.168.1.34 latency=0 multicast=yes wireless=IEEE 802.11abg
       resources: irq:18 memory:b5500000-b5507fff
  *-network
       description: Ethernet interface
       product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:09:00.0
       logical name: eth0
       version: 08
       serial: 6c:c2:17:5e:0b:a4
       size: 10Mbit/s
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl8106e-2_0.0.1 04/23/13 latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:58 ioport:4000(size=256) memory:b5404000-b5404fff memory:b5400000-b5403fff

When I am sitting just next to router then also only two signals showing up on my wifi. Please help me...

  • Which kernel are you using (please provide uname -a)? 3.17.x mainline kernel showed great improvement after I tried different devices (Intel, Realtek, ASIX) in the same situation (sitting just next to the hot spot and having very low connection quality). – Karl Richter Dec 14 '14 at 14:00
  • Linux aditya-HP-Pavilion-15-Notebook-PC 3.13.0-35-generic #62-Ubuntu SMP Fri Aug 15 01:58:42 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux – Aditya Lunawat Dec 14 '14 at 20:06
  • This is the output of the command – Aditya Lunawat Dec 14 '14 at 20:07
  • If you can, edit the question and delete your comments to make it readable. Do you have the possiblity to test a mainline kernel (following instructions at askubuntu.com/questions/119080/…)? – Karl Richter Dec 14 '14 at 20:30

Maybe your wifi is set to power saving?

power.d > set the wifi to no power savings.

iwconfig wlan0 power off

Check this out: https://help.ubuntu.com/community/PowerManagement/ReducedPower

Another option - driver issue:

Check this out: Asus X550L Weak Wifi signal ubuntu 14.04

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.