1

I am trying to setup my ubuntustudio 14.04 , 64bit as a bluetooth audio sink (service a2snk in a2DP), so that I can redirect music from the android phone to the pc and from there to my speakers.

I am following this guide which even though older can still work without too many modifications, up to the point where I have to load

sudo apt-get install pulseaudio-module-bluetooth
pactl load-module module-bluethooth-discover

Now, installing the module works as expected. But loading the module fails, so even though phone -> pc audio connection has been established, no bluetooth device pops up in pulse-audio and as such I hear no sound from the speakers.

This module appears in pulseaudio :

pactl list short modules | grep blue
9       module-bluetooth-policy 
22      module-bluetooth-discover   

Checking syslog, it states the following related info

Dec 14 12:32:19 starmaze NetworkManager[1243]: <info> (50:32:75:B3:DA:31): new Bluetooth device (driver: 'bluez' ifindex: 0)

where 50:32:75:B3:DA:31 is indeed the bluetooth MAC address of my android phone.

and a little later

Dec 14 12:38:47 starmaze pulseaudio[2663]: [pulseaudio] module-bluetooth-device.c: /org/bluez/942/hci0/dev_50_32_75_B3_DA_31 is not a valid BlueZ audio device.
Dec 14 12:38:47 starmaze pulseaudio[2663]: [pulseaudio] module.c: Failed to load module "module-bluetooth-device" (argument: "path=/org/bluez/942/hci0/dev_50_32_75_B3_DA_31 address=50:32:75:B3:DA:31 profile=a2dp_source source_properties=device.icon_name=blueman card_properties=device.icon_name=blueman"): initialization failed.

From these other threads: AU1 , AU2 , AU3 , AU4 , AU5

running pulseaudio -k does not seem to solve the issues and a contradictory statement to Disable=Socket in `/etc/bluetooth/audio.conf actually makes the service "a2dsnk" as broadcast from the pc to the phone to disappear.

What could be wrong? I guess the problem is pinpointed in a failure to load the bluetooth-discover module in pulseaudio or something related. But with all the info (sometimes contradictory) out there, I can not be certain. Can you help?

EDIT:

lsusb returns

Bus 006 Device 004: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)

lsusb -t returns

/:  Bus 06.Port 1: Dev 1, Class=root_hub, Driver=uhci_hcd/2p, 12M
    |__ Port 1: Dev 4, If 0, Class=Wireless, Driver=btusb, 12M
    |__ Port 1: Dev 4, If 1, Class=Wireless, Driver=btusb, 12M
    |__ Port 1: Dev 4, If 2, Class=Application Specific Interface, Driver=, 12M

lspci and lspci -nnk are over in pastebin. Not sure how this will help so I included all the output.

  • Did you ever figure this out? – Santa Claus Aug 30 '15 at 4:09
  • @SantaClaus it was always a problem of my bluetooth dongle. 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle is apparently notorious for not working correctly. so close, but no cigar... – nass Sep 1 '15 at 18:02
2

On my system this problem was caused by gdm starting a pulseaudio client and grabbing the bluetooth audio card before the user's client could. I fixed it by disabling pulseaudio for the gdm user: in

/var/lib/gdm/.config/pulse/client.conf

added:

autospawn = no
daemon-binary = /bin/true
  • This worked for me on 16.04 Beta 1 running on Dell XPS 13 9350 – ErlVolton Mar 4 '16 at 9:31
  • Suppose I want to fix this without rebooting. What command should I run if gdm has already grabbed the audio card? Thanks – spraff Jul 27 '16 at 14:46
0

This command might fix your issue

 sudo pactl load-module module-bluetooth-discover
  • nope the module is already loaded.. – nass Jan 1 '15 at 23:18
  • It seems that everything should be fine. I mean I can play audio from phone to the pc, but no bluetooth sound source appears in pulseaudio playback devices – nass Jan 1 '15 at 23:29
  • Can you include the results from lsusb -nnk and lsusb as it might be an issue with needed firmware on the PC's bluetooth device – Jeremy31 Jan 2 '15 at 11:50
  • Hi there, info is included, but lsusb -nnk returns "invalid options' for both "n" and "k". did you mean something else perhaps? – nass Jan 2 '15 at 12:37
  • yes I did lspci -nnk and lsusb – Jeremy31 Jan 2 '15 at 12:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.