I've got a fairly fresh install (a month old) of Kubuntu without much modification done to it and I'm having massive issues connecting to any wireless network. The computer can see the networks available and on trying to connect to my home network it will get to Setting Network Address before waiting for a while and then cutting the connection.

Sometimes the connection works, most of the time it doesn't. I've got this script which sometimes helps, but sometimes doesn't:

sudo ifconfig wlan0 down
sudo dhclient -r wlan0
sudo ifconfig wlan0 up
sudo dhclient wlan0

I don't really know too much about how to troubleshoot this issue (I'm a bit of a *ubuntu noob) - can anyone help?

here's my wifi card info :

   description: Wireless interface
   product: Centrino Advanced-N 6205
   vendor: Intel Corporation
   physical id: 0
   bus info: pci@0000:03:00.0
   logical name: wlan0
   version: 34
   serial: a0:88:b4:58:d1:c4
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
   configuration: broadcast=yes driver=iwlagn driverversion=2.6.38-10-generic firmware= build 35905 ip= latency=0 link=yes multicast=yes wireless=IEEE 802.11abgn
   resources: irq:48 memory:f2500000-f2501fff

It's probably not related to network manager but wireless drivers:


Solution is in the last post in the link, although it's not easy.

Just to avoid link rot: solution is to install from source compat-wireless using laptop's wifi firmware.

  • the instuctions were that difficult actually - helps that I'm running an X220 too! Thank you very much – Martyn Aug 8 '11 at 22:11
  • Actually this didn't work :( Initially it did, but still having problems connecting to wireless networks. – Martyn Aug 15 '11 at 15:03
  • 1
    If you changed kernel (updated your system) you have to recompile compat-wireless again. – Chris Hasiński Aug 16 '11 at 15:37
  • Yup - that worked - bonus points for you. – Martyn Aug 17 '11 at 10:10

I found another workaround. For me switching the hardware-wireless-switch off and on again "solves" the problem.

It's working on a x220i, Ubuntu 11.10 64bit...


Have you tried an alternate network manager such as Wicd?

sudo apt-get install wicd

Not promising it will work though. I was on the same boat as you a year or two back and it was soooo frustrating. D:

What wireless card do you have? Use this command to find out.

 gksudo lshw -C network
  • I don't have gksudo. Have done a bit of research but didn't find any good reasons to install it, do I need it? Also I haven't tried wicd, but a little worried about possible side effects if I install it. How easy is it to revert? – Martyn Aug 8 '11 at 14:35
  • 1
    Kubuntu uses: kdesudo – user4815 Aug 8 '11 at 14:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.