4

I just tried to install a program from Atom.IO, it's a really nice coding text editor. However, when I open the .deb file, it opens the software center and throws the error "Wrong architecture 'amd64'". I'm not sure what that means. Should I look for some alternative, or should I try the provided archive file instead?

Note that this is my first time using Ubuntu, or any form of linux other than Android, so I don't know much.

  • Why not search for the right version of the program in the Ubuntu repos, or a PPA, or the source code & build it yourself? Why re-install your whole OS because you downloaded one wrong file? – Xen2050 Dec 13 '14 at 11:35
  • Its a beta test, its not on the store yet I think. Besides, I'm just using it until I have a chance to send the PC to a shop to see why a Windows driver stopped working. (No internet, something about a blank IPConfig, I dunno but I was told to try a new OS. It works, but I have expensive Windows software so it's temporary. I may rig a dual boot tho, I love this) – Vector Lightning Dec 13 '14 at 19:25
  • Ah, ok. There's also the "persistent" option too for running only from a live usb, it stores OS changes to a file on the usb (or even a different partition of the usb for more space, might possibly work with a HD partition too, maybe). Then you wouldn't need to install Ubuntu to the hard drive at all. FYI, I run live all the time without persistence, just saving config files occasinally – Xen2050 Dec 14 '14 at 2:01
4

The wrong architecture refers to the type of processor your device is using.

You have downloaded a deb file designed for a processor running the amd64 machine language, commonly referred to as a 64bit processor or an x86_64 processor.

But either the processor you are using is not a 64 bit processor, or you have installed a version of Ubuntu not designed for 64 bit.

How old is this computer? If it is more then 5 years old, it may be a 32 bit processor, in which case you need the i386 package (or i486 or i686 or x86, depending on site notation, for most purposes, it's the same thing).

Is it a micro-device, like a beaglebone? It may be using an ARMv7 architecture.

Is it a chinese system, like a Lemote Yeelong? It may be using a MIPS architecture.

If you are certain it is an x86_64 processor, check to make sure you haven't installed the 32 bit version of Ubuntu.

  • Okay then. I don't know where "about this PC" is in Ubuntu, but I do know that it's main OS is Win8 64 bit... Hmm, how do I find out if I'm using Ubuntu 32 bit, and what do I download to swap it? – Vector Lightning Dec 13 '14 at 4:38
  • Click the little cog logo in the top right of the screen, and select "about this computer". What does it say under overview->os type? – Sir Substance Dec 13 '14 at 4:49
  • Apparently I have Ubuntu 32 bit... Darn it, just after I set up shop and everything... Wait wouldn't a 32b app break on a 64b processor? Either way, I know what to fix now. Thanks – Vector Lightning Dec 13 '14 at 5:11
  • x86_64 (64bit) is an extension/update of x86 (usually called "32 bit"). 32bit code doesn't automagically work on 64bit software, but since 32 bit on 64 bit compatibility is a feature of every major OS, I guess it's not hard. Unfortunately, it doesn't go the other way. Unfortunately, it seems the best way to move from 32 to 64 bit is to burn everything to the ground and start again. – Sir Substance Dec 13 '14 at 6:03
  • Well, at least its a Live Drive and not my primary OS... – Vector Lightning Dec 13 '14 at 8:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.