0

I am having trouble with getting my wifi to work. I installed ubuntu alongside windows 8.1 (Its really weird, I choose UEFI mode to go into windows and legacy mode to go into Ubuntu 12.04). Anyhow the only internet that I can get is a wired internet connection and my home wifi (I added that when installing). There is no wifi icon in the top bar but I am connected to our home wifi because I can load webpages. The driver I would need is Realtek RLT8188ee, which has no linux variation available. I tried this guide here Wireless not working on Toshiba Satellite C55-A5281 .

Every thing was fine until I ran the make and sudo make install commands. Errors are here http://i.imgur.com/UHGlIN8.png?1 (red is make blue is sudo make install, these were the only errors I saw).

In case anyone cares I ran uname -mr in terminal and this came out 3.13.0-41-generic x86_64

I also ran the final command sudo modprobe rlt8188ee and it just returned to a command line, like what happens when a command is done, so i assumed that worked or depended on the previous commands to work.

So what do I do? How do I fix the driver? I'm not the most advanced in Ubuntu so if you could break things down a little more, or even explain what it does that would be great.

Oh and this is AMD architecture

As asked by chili555 I ran those commands and pasted the results here: http://paste.ubuntu.com/9503274/ The first block was the first command and so on and so forth.


Thought I'd give an update: The wifi is now working after I ran updates and restarted. I still cannot see wifi options and status in the top bar, but i can see it in settings->network.

Sorry to waste your time.

0

Although the link you gave asks that you compile backports-3.11, you compiled the much older and incompatible backports-3.2. In fact, rtl8188ee is included in Ubuntu 14.04, which uses kernel 3.13, by default! There is no need to compile anything:

ubuntu@ubuntu:~$ modinfo rtl8188ee
filename:       /lib/modules/3.13.0-24-generic/kernel/drivers/net/wireless/rtlwifi/rtl8188ee/rtl8188ee.ko
firmware:       rtlwifi/rtl8188efw.bin
description:    Realtek 8188E 802.11n PCI wireless
license:        GPL

Please give us some diagnostics so we may see what is going wrong:

lspci -nn | grep 0280
rfkill list all
dmesg | grep rtl

As the results may be lengthy, please paste them here and give us the link: http://paste.ubuntu.com. I will then edit this answer to propose a solution.

0

Apparently, the driver was working better a few releases ago, so the backport driver was not that bad of a suggestion. I tried it, and it worked better than the one in the 3.13.0-32 kernel. However, the new driver that Larry Finger has seems to work far better than either one. You can find directions here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.