2

I have Ubuntu running on Virtualbox and I used GuestAddition.iso so that when I run the VM it opens in a full screen mode. I ran sudo apt-get update and sudo apt-get dist-upgrade to upgrade the old packages that were installed.

There has been no upgrade of the OS. It is still 12.04.

I successfully updated the packages but when I restarted my VM, I noticed that I again had gone back to its previous screen size and the guest additions ISO as also automatically unmounted. I remounted it but still Ubuntu would not resize itself.

What should I do?

  • "Certain installations"?? You need to be more specific - mainly, did you upgrade VirtualBox or Ubuntu? – Marty Fried Dec 12 '14 at 21:19
  • @MartyFried Sorry for that, I have edited the post – Animesh Pandey Dec 12 '14 at 21:47
2

Even though it is still 12.04, you have probably upgraded the kernel version.

You will need to re-install the Virtualbox Guest Additions - mounting the additions disk is not enough (or needed after installation), it needs to be installed.

  • Yeah, my earlier version of Guest-additions was 4.3.10 after upgrade it was 4.3.20 and that is why this was happening. I re-installed that and it started to function properly. Thanks – Animesh Pandey Dec 13 '14 at 0:21
  • I too was facing the same issue after running the update/upgrade and couldn't switch to fullscreen, Reinstalling the Guest Addons fixed it.!!! – Mohd Abdul Mujib Feb 6 '17 at 15:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.