1

I have recently installed ubuntu 14.04 on one of my laptops. Since I found it working a lot faster and efficiently than windows, I decided to install it on my older, x32 hp Pavilion dv6000. I installed 14.10 onto it, but during the installation I realized that it wouldn't let me connect to any wifi (I am using ethernet instead). I had a look at many tutorials that claimed to solve the problem (for example: Installing Broadcom Wireless Drivers ) and this is what the terminal threw back at me.

lspci -nn -d 14e4:

02:00.0 Network controller [0280]: Broadcom Corporation BCM4311 802.11b/g WLAN [14e4:4311] (rev 01)

$ sudo apt-get purge bcmwl-kernel-source

E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.

I get this error whenever I try a command that has anything to do with my wireless driver.

So I tried to run sudo dpkg --configure -a

$ sudo dpkg --configure -a

Configuring bcmwl-kernel-source (6.30.223.248+bdcom-0ubuntu1) ... Removing old bcmwl-6.30.223.248+bdcom DKMS files...

-------- Uninstall Beginning -------- Module: bcmwl Version: 6.30.223.248+bdcom

Kernel: 3.16.0-25-generic (i686)

Status: Before uninstall, this module version was ACTIVE on this kernel.

wl.ko: - Uninstallation - Deleting from: /lib/modules/3.16.0-25-generic/updates/dkms/ - Original module - No original module was found for this module on this kernel. - Use the dkms install command to reinstall any previous module version.

depmod..........

DKMS: uninstall completed.


Deleting module version: 6.30.223.248+bdcom

completely from the DKMS tree.

Done. Loading new bcmwl-6.30.223.248+bdcom DKMS files... Building only for 3.16.0-25-generic Building for architecture i686 Building initial module for 3.16.0-25-generic Done.

wl: Running module version sanity check. - Original module - No original module exists within this kernel - Installation - Installing to /lib/modules/3.16.0-25-generic/updates/dkms/

depmod..........

DKMS: install completed.

Then it just stays on "DKMS: install completed." although the process does not end. When I tried to end the process (^C) I got this: dpkg: error processing package bcmwl-kernel-source (--configure): subprocess installed post-installation script was interrupted There was an error while processing: bcmwl-kernel-source

Any help would be appreciated. Thanks

1

With a temporary internet connection:

sudo apt-get update
sudo apt-get purge bcmwl-kernel-source
sudo apt-get install firmware-b43-installer

Reboot and tell us if your wireless is working.

  • I installed all the packages and I can now see WiFi under connections, but unfortunately it is greyed out and it's unclickable... – Radek Dec 13 '14 at 16:29
  • Also... $ rfkill list 0: phy0: Wireless LAN Soft blocked: no Hard blocked: yes – Radek Dec 13 '14 at 16:33
  • Do you have a wireless switch or key combination? microcentertech.com/tech_center/DB/HowTos/images/… Does it respond to key presses? – chili555 Dec 13 '14 at 16:40
  • Yes I have a wireless switch on the front of my laptop (not on the keyboard) (It looks like this studentbuyingguide.com/wp-content/uploads/2008/06/… ) but it is not responding whereas with windows it was – Radek Dec 13 '14 at 16:50
  • Ok. Thanks so much I managed to fix it by turning airplane mode on/off and messing about with the switch. It's working now. Thanks – Radek Dec 13 '14 at 17:02
0

Or you could use the open source b43 driver which works just fine with your 4311 chip. You just need to add the linux-firmware-nonfree package for the firmware. And most important, clean out all the other broadcom stuff you installed. Much of that will suppress the working of the b43 driver. Check for any exact lines like "blacklist b43" in any files in /etc/modprobe.d and delete them. At least that's how it used to work, things do change and I no longer have a machine with such a chip. The firmware should be put into /lib/firmware/b43, if nothing shows up, you probably need to fall back to the b43-fwcutter package to "cut" out the firmware from a broadcom driver. Search around here for solutions, there are many. The proprietary drivers started having problems several years ago and I'm not sure they were ever solved.

  • linux-firmware-nonfree is obsolete. Please use firmware-b43-installer instead. – chili555 Dec 12 '14 at 20:55

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.