2

After the last update, I am having this problem with two monitors resolution:

GDBus.Error:org.gtk.GDBus.UnmappedGError.Quark._gnome_2drr_2derror_2dquark.Code2: could not set the configuration for CRTC 63

I can see how nvidia-settings just detect one screen with with a resolution equal to 3286x1080 which is 1366 + 1920 (I have two screens 1366x768 of my laptop and 1920x1080 of an external monitor). The problem appears in the second screen. I can see 1/3 of the left part on the right size of the screen.

Edit: If I runxrandr display:

Screen 0: minimum 8 x 8, current 3286 x 1080, maximum 16384 x 16384
LVDS1 connected 1366x768+1920+0 344mm x 193mm
   1366x768       60.0*+
   1360x768       59.8     60.0  
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        59.9  
VGA1 disconnected
HDMI1 connected 1920x1080+0+0 509mm x 286mm
   1920x1080      60.0*+
   1680x1050      59.9  
   1280x1024      75.0     60.0  
   1440x900       59.9  
   1280x960       60.0  
   1280x800       59.9  
   1152x864       75.0  
   1280x720       60.0  
   1024x768       75.1     70.1     60.0  
   832x624        74.6  
   800x600        72.2     75.0     60.3     56.2  
   640x480        75.0     66.7     60.0  
   720x400        70.1  
DP1 disconnected
VIRTUAL1 disconnected

Also I noticed that the refresh rate to the second screen is very low.

2
  1. Install arandr

    sudo apt-get install arandr
    
  2. Run xrandr.

    If your chosen resolution exists (regardless of which monitor it appears by) then skip the next step

  3. If your resolution does not exist, create it by doing the following:

    1. In this example the resolution I want is 1280x1024 cvt 1280 1024. This will create a modeline like this:

      "1280x1024_60.00" 109.00 1280 1368 1496 1712 1024 1027 1034 1063 -hsync +vsync
      
    2. Create the new mode:

      xrandr --newmode "1280x1024_60.00" 109.00 1280 1368 1496 1712 1024 1027 1034 1063 -hsync +vsync
      
  4. Add the mode (resolution) to the desired monitor (VGA-1):

    xrandr --addmode VGA-1 "1280x1024_60.00"
    
  5. Run arandr and position your monitors correctly

  6. Choose 'layout' then 'save as' to save the script
  7. I found the best place to load the script (under Xubuntu) is the settings manager:

    xfce4-settings-manager
    

OR

Menu -> Settings -> Settings Manager -> Session and Startup -> Application Autostart

If you have also take problem must comment me.....:)

  • If I run xrandr it seems ok. I added what it shows in my edit. Thank you for your help :) – Daniel Oñoro Dec 15 '14 at 8:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.